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Preface 
The Cardbox Server does two things: 

1. It gives shared access to Cardbox databases, so that many people can use the 
same database at the same time. 

2. Optionally, it also gives remote access to Cardbox databases, so that you don’t 
need to be on the same computer or even the same network as the database 
you are using. 

This book describes what the Cardbox Server does, and how to set it up and use it. 

If you’re familiar with Cardbox 2.0 
If you have used a networking version of an earlier version of Cardbox for Windows, 
you’ll find that the architecture is now very different, although from the user’s point of 
view hardly anything has changed.  The Appendix on page 45 summarises the 
differences and suggests a strategy for changing over to the new version. 

The Linux version 
The main part of this book covers the Windows version of the Cardbox Server.  The 
Linux version works in the same way but there are differences in how you set it up 
and configure it.  We recommend that you read through this book and then look at 
the section starting on page 50 for details of installing, configuring and running the 
Linux version of the Cardbox Server. 

 





 

  

Part One 
Planning 

The client-server architecture; an introduction to 

TCP/IP; basic requirements; some possible 

configurations; security; licensing. 
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Client-server architecture 

The “one program” rule 
There is one simple rule that applies to Cardbox database files: 

• Only one program at a time is allowed to open a Cardbox database file. 

We apply this rule to ensure that your Cardbox data remain secure and undamaged.  
Earlier versions of Cardbox allowed many users to open the same database file at 
the same time, but although this worked well most of the time, it did make data 
vulnerable to bugs and misconfigurations in the operating system’s networking 
software. 

Sharing databases among users 
So what do you do when you want several people to open the same database at the 
same time?  This is where the client-server architecture comes in: 

The Cardbox Server opens the database file. 

Each user’s copy of Cardbox communicates with the Cardbox Server when it 
wants access to the database. All database operations – searching, editing, 
display and printing – are done in the same way: Cardbox sends a request to the 
Cardbox Server, the Cardbox Server does what is requested and sends a 
response back to Cardbox.  In other words, this is a client-server architecture 
with Cardbox as the client and the Cardbox Server as the server. 

From the user’s point of view, there is virtually no difference between opening a 
database file directly and communicating with the Cardbox Server.  When opening 
the database, the File > Open command opens a window with multiple pages: the 
File > Open » My Computer page is for opening database files on the user’s own 
computer and the File > Open » Server page is for opening databases on a Cardbox 
Server. 
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Choosing the server location 
The requirements for someone to be able to access a Cardbox database using the 
Cardbox Server are very simple: 

1. The Cardbox Server must be running on a computer that is using either 
Windows or Linux.  It must be running whenever someone wants to open a 
database on it. 

2. The user’s copy of Cardbox must be able to establish a TCP/IP connection to 
the computer on which the Cardbox Server is running. 

3. The Cardbox Server program must be able to open the database files that the 
user is requesting. 

The server must be running 
The first requirement of the computer that runs the Cardbox Server is that it should 
be running whenever anyone wants to open a Cardbox database.  In many offices 
there is already a file server that holds all the shared files for the office, and this will 
often be left running continuously for days, weeks, or months at a time.  Such a 
computer is a good choice for running the Cardbox Server as well. 

It may be that you can’t use the office file server to run the Cardbox Server.  The 
reasons for this may be technical (for example, the server runs Novell software and 
not Windows or Linux) or they may be political: perhaps your system administrators 
don’t want any other software to run on the file server.  In that case, you can run the 
Cardbox Server on any other computer on the network, but you do need to make 
sure that the computer will be switched on whenever anyone needs to open a 
shared Cardbox database. 

The server must be accessible through TCP/IP 
Modern local area networks use TCP/IP by default, but if you are running an older 
network then you may have to check that the TCP/IP protocol is available and install 
it if it isn’t.  The Networking control in the Windows Control Panel lets you view the 
installed protocols and add new ones. 

If there are any firewalls on your system, you will have to ensure that they are set up 
so as to permit client (user) computers to open a TCP connection to your server 
using port number 3105. See page 49 for more 

details.
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The server must be able to open the files 
The commonest arrangement is for all the Cardbox database files to be stored on 
the same computer that is running the Cardbox Server: this is also the best 
arrangement because it gives the fastest file access. 

This is not an absolute requirement.  For example, your company’s policies may 
dictate that the Cardbox Server should run on a different computer from the main file 
server, but that all files should be stored on the file server. 

If you do have the database files on a computer other than the Cardbox Server one, 
and you choose to run the Cardbox Server as a Windows system service, then there 
is a technical point that you have to be careful of.  Windows will, by default, run 
system services under a special user account called LocalSystem. The 
LocalSystem account does not, by default, have access to any files outside the 
computer it is running on. In this case, if your database files are on a different 
computer then you will have to use the Windows Control Panel to change the 
account used by the Cardbox system service. 

Cardbox users ought not be able to open the files 
If databases are being handled by the Cardbox Server then there is no need to put 
the database files (.fil and .fmt) into a directory that is shared on the network, 
and in fact it’s better not to do so. 

If you do have your database files in a shared directory then this isn’t a disaster, but 
it does mean that an inquisitive or ignorant user could navigate to that directory in 
Windows and try to open a Cardbox database by double-clicking on the database 
file. If no-one is currently using the database through the Cardbox Server then this 
attempt will succeed but it will mean that no-one else can share that database until 
the offending user has been identified or evicted. 
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Possible configurations 

Intranet / LAN 
The simplest configuration is when you are using a local area network (LAN) in your 
office.  In this case, run the Cardbox Server on your file server.  Find out the 
computer name (in networking terms) of your file server, and every Cardbox user 
can then use File > Open » Server to connect to the server. 

Internet 
Any computer connected to the Internet can in principle run the Cardbox Server and 
hold Cardbox databases.  This is useful if you work in a very decentralised 
organisation with no obvious place to have a file server, or if you are publishing 
databases that should be available to a wide audience. 

The computer that runs the Cardbox Server can be in your office or elsewhere. 

An Internet server in your office 
If one of your computers is already permanently or semi-permanently connected to 
the Internet then you can use it to run the Cardbox Server.  You’ll have to consider 
the security implications of allowing connections from outside into that computer, 
and you should certainly make sure that all your Cardbox databases are protected 
by user profiles and passwords. 

If you have a computer with a dial-up or cable connection and want to use it to run 
the Cardbox Server then you will need to make sure that incoming connections are 
not blocked, because some Internet service providers restrict the incoming 
connections that are allowed to get through.  You will also need to check if your 
computer’s IP address is statically or dynamically allocated, and if it’s dynamically 
allocated then you’ll need to do something about it: see page 48. 

A remote Internet server 
Another option is to rent a server from a hosting service and run your own Cardbox 
Server on it.  This is probably the best option for most small to medium-sized 
organisations that don’t want any open connections from the Internet into their own 
networks.  If you already have a Web server of your own (as opposed to just renting 
space on a shared server) then you may be able to run the Cardbox Server on this. 

It is also possible to pay someone to host your Cardbox databases on their own 
Cardbox server.  At the time of writing we can’t predict who will offer this service or 
how much it will cost, so please have a look at the Cardbox web site for details. 

If your LAN connections are 
protected by firewalls, 

see page 49 for how to allow 
Cardbox connections.
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Intranet/LAN plus guests 
It’s quite common to have an office LAN and to want to allow staff members to 
connect into it when they are at home or when they are travelling.  The implications 
for Cardbox depend on exactly how this is being done. 

Remote desktops 
If the user is connecting to his own office PC and effectively viewing its desktop on 
his own home PC or laptop, then there is nothing you need to do.  Cardbox will be 
running on the office PC and not on the remote computer, so nothing has changed. 

Virtual private networks 
The purpose of a virtual private network (VPN) is to behave just like a LAN.  This 
means that no reconfiguration is necessary from the point of view of the Cardbox 
Server, but you should make sure that the VPN itself is configured to transmit data 
on TCP port 3105. 

Internet connections 
If you have a computer on your LAN that has an Internet connection, then remote 
users can connect to it.  This is the simplest way of allowing access by people who 
are travelling. 
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Security 

Controlling connections 
If the Cardbox Server is running on a computer that is part of your LAN and has no 
external connections, there is nothing that needs to be done. 

If the Cardbox Server is running on a computer that has both a LAN and an Internet 
connection, you can choose whether or not to allow the Cardbox Server to respond 
to connection requests coming in from the Internet.  The Connections page of the 
Cardbox Server Control lets you do this: see page 22. 

If you want more precise control of what incoming connections are to be allowed (for 
example, allowing or disallowing connections depending on where they are coming 
from) then you will have to use a firewall and configure it appropriately. 

After a connection has been made 
In Cardbox, File > Open » Server presents the user with a list of available 
databases.  You can choose to make your databases invisible so that they do not 
appear on this list: a legitimate user will know what database name to type in, while 
a outsider would have to guess.  You can also have some databases that are visible 
and others that aren’t. 

User profiles and passwords 
You can set up user profiles so that different people have different levels of access: 
certain data can be made invisible and certain commands can be disabled. 

If all the user profiles require passwords then an intruder would have to guess the 
password in order to obtain access.  Another possibility, if you are publishing data 
using your Cardbox Server, is to have one profile that doesn’t require a password 
but gives very restricted access (no editing allowed, certain fields hidden) while 
administrators can use other profiles that give them more privileges. 

Encryption 
By default, Cardbox encrypts all communications between the client and the server.  
It is not possible for an outsider to intercept an authorised user’s communications 
and extract information from them.  In particular, passwords are never transmitted in 
a form that would allow them to be read. 

For more about profiles, 
see the relevant section of 

The Cardbox Book.
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Licensing 
There are three editions of Cardbox available. 

The Client Edition is available free of charge.  It can be downloaded from our Web 
site. 

The Home Edition is a straightforward version of Cardbox suitable for most single-
user applications.  It is normally supplied in book form, with a CDROM in the 
back of the book. 

The Professional Edition has additional advanced features for use in business or 
where several different people may be using the same databases. 

The Cardbox Server is licensed according to the number of Client Edition and Home 
Edition users who are allowed to connect to it simultaneously.  There is no limit to 
the number of Professional Edition users who can connect to the Cardbox Server. 

Here are some examples of how this can work: 

Professional Edition only – you install the Professional Edition of Cardbox for 
everyone on your network.  This is the simplest and commonest case. 

Client Edition, plus an n-user server licence – you install the free Client Edition of 
Cardbox for everyone on the network.  On the Cardbox Server, you install a 
licence that is rated for your maximum expected number of simultaneous users.  
Your users will be unable to create databases on their own computers, because 
your Cardbox Server licence only applies to databases on the server; but this 
restriction can be an advantage if you are trying to maintain some sort of control 
over what your users are doing. 

People working from home – the crucial question is: do you need them to be able 
to make changes to databases even when they’re not connected to your 
system?  If you do, then give them their own copies of the Professional Edition 
and let them connect to your server when they need it.  If you don’t, then give 
them the free Client Edition, and make sure your server licence has the capacity 
to handle the extra users. 

People working from Internet cafés – they will  want to download Cardbox and 
then to connect to your server to do some work.  Because these people won’t be 
using the Professional Edition, your server will have to have a licence that 
covers them. Work out the maximum number of travelling users you expect to 
have connected to your server at any one time and install a licence that size on 
your server. 

 

For ways of installing a 
multi-user Professional 

Edition licence, 
see page 11.
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As you can imagine, these simple rules can give rise to a large number of different 
combinations.  If you are planning a network, have a look at the advice on the 
Cardbox web site, or talk to us or to one of our distributors. 

What about the Home Edition? 
In principle you could give the Home Edition to someone who was working from 
home, to give the user the ability to edit local databases at less cost than the 
Professional Edition.  You should think carefully before doing this, however, because 
you would have to make sure there’s a spare licence available on your Cardbox 
Server for when that user connects to it, and the cost of that spare licence could 
outweigh the saving that you have made by going for the Home Edition. 
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Professional Edition licences 
The commonest use of the Cardbox Server is to provide shared database access for 
users of the Professional Edition of Cardbox.  In that case you will probably have a 
single, multi-user licence for the Professional Edition.  You have the following 
choices: 

A single shared installation of Cardbox 
1. Install Cardbox once, and place the program files and licence in a shared 

directory that is accessible to all potential users of Cardbox. 

2. To start using Cardbox on a workstation that has not previously used it, navigate 
to the shared directory (using Windows Explorer), find CARDBOX3.EXE, and 
double-click on it.  Cardbox will then create all the necessary shortcuts so that 
you can run it easily. 

Individual installations, shared licence 
Some organisations have a policy of installing software on each user’s workstation 
rather than centrally – this is normally done to reduce the load on the network. In this 
case you have to do the following: 

1. Create a shared directory that will contain the licence files. 

2. Install Cardbox on a workstation, and tell the Setup program that you want to 
store the licence files separately, in that shared directory.  For this first 
installation, you have to have read/write access to the shared directory so that 
Setup can put the licence files there; once this has happened, read/write access 
is not needed to run Cardbox itself. 

3. Now install Cardbox on each of the other workstations.  Again tell Setup that the 
licence files are in the shared directory.  Read-only access to the shared 
directory is sufficient, because the licence files have already been created and 
don’t need to be created again. 

Individual installations, server-based licence 
1. Install the Cardbox Server. 

2. Install the licence in the Licences page of the Cardbox Server Control (p.24). 

3. Now install Cardbox on each workstation that needs it.  Don’t give Setup any 
licence, because you have already installed the licence on the Cardbox Server. 
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With this arrangement, individual users’ copies of Cardbox will be the Client Edition, 
which will not allow them to create databases on their own computers, only on the 
Cardbox Server. 

Individual installations, licence server 
1. Install the Cardbox Server. 

2. Install the licence in the Licences page of the Cardbox Server Control (p.24). 

3. Turn on the “Lend Licences” option (p.26). 

4. Now install Cardbox on each workstation that needs it.  Tell Setup that Cardbox 
should borrow a licence from your Cardbox Server when the user runs it. 

With this arrangement, individual users’ copies of Cardbox will work as the 
Professional Edition and allow them to create and edit databases on their own 
computers. 

First and second class citizens 
Some system administrators like to divide their users according to how much they 
are allowed to do for themselves.  Storing licences on the server allows you to do 
this.  Set up the Cardbox Server so that it is willing to lend licences, but only 
configure some of your users’ Cardbox installations to borrow those licences.  The 
remaining users, the “second-class citizens”, will be able to use the databases that 
you provide for them on the Cardbox Server, but they will not be able to create 
databases on their own computers. 

 



 

 

Part Two 
Setup 

How to install the Cardbox Server. Opening the 

Cardbox Server control; starting and stopping the 

server; the options that you can set. Installing and 

removing user licences; how to set up a licence server. 
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Installing the Cardbox Server 
You should perform the installation procedure directly on the computer that you will 
be using to run the Cardbox Server.  If you don’t have access to that computer’s 
keyboard, mouse and CDROM drive,  see page 16. 

Installing from a CDROM 
5. Insert the CD into the computer you have chosen to use as a server. 

6. Depending on your Windows configuration, the Cardbox Server setup program 
may start automatically.  Wait a moment or two to give it time to do this.  If 
nothing happens, open the CDROM in Windows Explorer and double-click on 
SETUP.EXE (Windows may report this program name as simply Setup). 

7. Follow the on-screen instructions. 

Installing from the Internet 
The same page that lets you download the Cardbox program files will also give you 
instructions for installing Cardbox after you’ve downloaded it. 

Inserting licence details 

 

During the installation process, the setup program will show a Licence Management 
page that tells you what licence is installed in your copy of the Cardbox Server.  If 
you are installing the Cardbox Server for the first time, this page will be blank and 

For the Linux version, see 
page 50
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you will have to enter the licence details before continuing.  If you got the software 
on CDROM, the details will be on the CDROM, on a label stuck to the CD envelope, 
or on a separate piece of paper.  If you got the software by download, you will have 
received the licence details by email. 

Always make sure that you keep a note of your licence details, because 
you will need them if you ever want to re-install the Cardbox Server. 

After installation 
Once the installation is complete, the Cardbox Server control (part of the Windows 
Control Panel) will start, so that you can configure the program according to your 
needs.  See page 17 for more information. 

Removing the Cardbox Server 
To remove the Cardbox Server, open the Windows Control Panel and select 
“Add/Remove Programs”, then find the Cardbox Server in the list of installed 
programs and select “Remove”. 

If you don’t have physical access to the server computer 
If you don’t have access to the keyboard and mouse of the actual server, you have 
two choices. 

Remote desktops 
Various solutions exist that allow you to use a remote server across the network, so 
that you see its desktop on your screen and so that keystrokes and mouse clicks go 
straight to the server.  If you have such a setup, use it: the installation and 
configuration of Cardbox will be just the same as if you were using the server 
directly. 

Network drives 
If you can get access to the directory where the Cardbox Server is to be installed 
(this will be a directory on the file server, visible to workstations as a network 
directory), you can insert the CDROM into your computer’s CD drive and use the 
standard Setup method to install the Cardbox Server in that network directory (you 
need full read/write access while doing this). 
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The Cardbox Server control 

Opening the Cardbox Server control 
The setup program installs an item labelled “Cardbox Server” into your Control 
Panel.  To open the Cardbox Server control, double-click on this item. 

If the Control Panel item isn’t there, you can open the Cardbox Server control 
directly by using Windows Explorer to locate CBOX3CPL.EXE and then double-
clicking on it.  (The Control Panel item will be missing if, for instance, you installed 
the Cardbox Server from a different computer from the one you are now using). 

If you’re running the Cardbox Server as a program rather than as a Windows system 
service, you’ll also have (on the computer where the Cardbox Server is running) a 
small icon in the Windows system tray.  Double-clicking on that icon will also open 
the Cardbox Server control.  

• Windows sometimes hides unused system tray icons, in which case you may 
have to expand the system tray to see the Cardbox Server icon. 

If you don’t have physical access to the server 
If you don’t have physical access to the server and you don’t have remote access to 
the server’s desktop, you can still run the Cardbox Server control as long as the 
relevant directory is available as a network directory on your workstation: simple 
double-click on CBOX3CPL.EXE and the Cardbox Server control will open. 

If you do this, you should note that although all the server configuration can be done 
remotely from your workstation, you won’t be able to start or stop the Cardbox 
Server or discover whether or not it is running.  This is because CBOX3CPL.EXE is 
running on your workstation while the Cardbox Server is running on the server, and 
there is no way for the two programs to communicate if they are on different 
computers. 

Depending on your 
Windows Explorer 

settings, you may find the 
relevant icon labelled 

simply CBOX3CPL.
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Starting and stopping the Cardbox Server 
The Start page of the Cardbox Server control lets you choose how the Cardbox 
Server should run and lets you start and stop it. 

 

Note that although this screen has OK and Cancel buttons, all actions on the Start 
page take place immediately without waiting for you to press OK. 

This page is only meaningful if you are running the Cardbox Server control using the 
actual computer that is running the Cardbox Server (either directly or through a 
remote desktop program).  If you run the control using a workstation, then it won’t be 
able to see or influence the status of the Cardbox Server. 

Running the server as a program 
In this mode the Cardbox Server is an ordinary program.  While it is running, it will 
appear as a small icon in the system tray: you can double-click on the icon to open 
the Cardbox Server control.  You can also stop the Cardbox Server quickly by right-
clicking on the icon and picking the appropriate item from the menu that pops up. 

You can tell Windows to start the Cardbox Server automatically: in this case the 
Cardbox Server will start as soon as you log in to Windows. 

Windows sometimes 
hides system tray icons 
when you haven’t used 
them for a while: if this 

happens, you may need 
to  expand the system 
tray to see the hidden 
Cardbox Server icon.
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You can also put icons on the desktop or in the Start menu to make the Cardbox 
Server easier to start. 

Running the server as a system service 
System services are available only in Windows NT, 2000, XP and above. You 
need to be an administrator to set up the Cardbox Server as a system service.  

Unlike an ordinary program, a system service runs in the background and is not 
directly visible from your desktop.  Buttons on the Start page let you start and stop 
the Cardbox Server; and you can also configure it to start automatically as soon as 
Windows starts, before anyone has even logged on. This is a good choice if your 
computer is to run as an unattended server. 

Windows system services normally run in a special account called LocalSystem, 
which has relatively few privileges.  You should make sure that your file permissions 
are set up in such a way that this account can read (and if appropriate write) your 
database files.  You can change the account that is used to run the Cardbox Server.  
To do this, open the Windows Control Panel, select Administrative Tools, then 
Services, and then double-click on Cardbox Server. 

If the database files that you want to share using the Cardbox Server are not on the 
computer that you are running the Cardbox Server on, this means that the Cardbox 
Server will have to access those files across the network.  In that case, 
LocalSystem will not be the right account because it does not normally have 
access to network resources, and you should change the account to something 
more suitable. 

How to confuse the Cardbox Server control 
You can cause some confusion by doing the following: 

1. Set up the Cardbox Server to run as a system service. 

2. Using Windows directly, stop the Cardbox Server service but don’t uninstall it. 

3. Using Windows directly, run the Cardbox Server as a program. 

Now, if you open the Cardbox Server control, it will tell you that the Cardbox Server 
is installed as a system service (because it still is) and that it isn’t running (because 
the system service isn’t): it won’t see that the Server is running as a program.  If you 
try to start the system service, you’ll probably get an error because the Cardbox 
Server is already running. 

This is nothing to worry about.  You can simply ignore the Start and Stop buttons, or 
you can switch to “Run the server as a program”, in which case the Cardbox Server 
will be uninstalled as a system service and the status display will be correctly 
updated.  

This is an uncommon 
configuration: usually 

you’ll put the database 
files on the same 

computer as the Cardbox 
Server.
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Shutting down Windows 
You don’t need to stop the Cardbox Server before you shut down Windows: it will 
close itself automatically when Windows shuts down.   

Because the Windows shutdown may be triggered by a power failure, and there may 
be only a few seconds of power left, the Cardbox Server is designed to shut down 
as fast as possible while still preserving data integrity.  If necessary, it will interrupt 
long-running operations such as indexing and continue them automatically the next 
time the database is opened. 
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The Server page 
The settings on this page take effect when you press OK.  Any changes you make 
will affect new connections from Cardbox users to the Cardbox Server, but existing 
connections will continue to use the original settings. 

 

Server identification 
You can enter a few words of description here.  These will appear to Cardbox users 
when they connect to this server, in the bottom left-hand corner of the File > Open » 
Server command.  The server identification is optional: it is there purely for the 
convenience of users. 

Access to databases 
You can choose whether the server is to give read-only access to the databases it 
shares, or read/write access (allowing records to be added, edited, and deleted).  If 
you want some databases to be read-only and others to be read/write, select 
“Read/Write” here and then use Windows Explorer to mark selected database files 
(.fil and .fmt) as read-only. 

In a normal office 
network, Read/Write is 

the usual setting.

The Automatic Directory 
option is described on 

page 35.
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The Connections page 
The settings on this page take effect when you press OK.  If you change the 
connection rules then this will not affect any existing connections from Cardbox 
users 

 

Once the Cardbox Server has started, it waits for Cardbox users (“clients”) to try to 
connect to it. This page lets you control how those connections should arrive, by 
choosing which IP address the Cardbox Server should use when “listening” for client 
connections.  In most cases you will be able to leave the setting at its default value, 
which is “Accept all connections”. 

The Connections page lists all the connection types that Windows reports as being 
available: the list you see, and the associated descriptions, will depend on your 
computer’s configuration and on the exact version of Windows you are using.  The 
different connections are identified by their IP addresses. 

For more about  
IP addresses,  
see page 47.
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LAN connections 
In the example, “NVIDIA nForce MCP Networking Controller” is an Ethernet 
networking card.  It has the IP address 192.168.0.1 (this was set up when we set up 
networking on this computer) and any connection that comes in on this address will 
have come from another computer on the local Ethernet network. 

WAN/Internet connections 
In the example, “WAN (PPP/SLIP) Interface” is a connection to our Internet service 
provider (ISP).  At the time that we opened the Connection page to get this example, 
our IP address was 81.135.134.220, but because this is a dial-up connection the IP 
address varies from one session to the next.  Any connection that comes in on this 
address will have come from a computer elsewhere on the Internet. 

Loopback connection 
“Loopback” means a connection from this computer to itself.  If you run the Cardbox 
Server on a computer and then run Cardbox on the same computer and tell File > 
Open » Server to connect to 127.0.0.1 or localhost, it will connect to the 
Cardbox Server on your own computer.  This is useful for testing purposes or when 
setting up a server. 

If you select anything other than “Accept all connections” then you can tell the 
Cardbox Server to listen on the loopback connection as well by turning on the option 
“Also accept connections from the server’s own computer”. 

Port number 
By default, the Cardbox Server listens for incoming connections on port 3105.  Port 
3105 is officially reserved for Cardbox, but if for any reason you need to use a 
different port then you can specify it here. 

For more about  
loopback,  

see page Error! 
Bookmark not defined..
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The Licences page 
When you install the Cardbox Server, you install a licence for it as part of the setup 
procedure (see page 15).  This lets you run the Cardbox Server and allows any 
number of Professional Edition users of Cardbox to connect to the server and open 
databases. 

The Licences page lets you add user licences to the Cardbox Server, to enable it to 
serve Cardbox users who haven’t got their own Professional Edition licence. 

 

To add a licence 
1. Click on “Add”. 

2. Fill in the form with the licence details, and press OK. 

To change an existing licence 
1. Highlight the licence in the User Licences list. 

2. Click on “Change”. 

3. Fill in the form with the revised licence details, and press OK. 

For the principles of 
licensing, see “Licensing” on 

page 9.
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To remove an existing licence from the list 
1. Highlight the licence in the User Licences list. 

2. Click on “Delete”. 

To confirm or discard your changes 
None of these changes will take effect until you have pressed OK to close the 
Cardbox Server Control.  If you make a mistake, just press Cancel and all your 
changes will be discarded. 

User licences 
The number of users specified in the User licence determines the maximum number 
of users who can simultaneously have databases open on this Cardbox Server 
under that licence; but these can be different users at different times.  

Remember that Professional Edition users are automatically allowed to connect 
without requiring any User licence on the server. 

Read-Only User licences 
A Read-Only User licence allows users of the Client or Home Edition of Cardbox to 
connect to the server and open databases in a read-only mode: that is, in a mode in 
which they can search, view, and print records but cannot make changes to the 
database. 

For licensing purposes, the Cardbox Server considers a read-only user to be 
someone whose is currently using a read-only user profile: that is, one that doesn’t 
allow editing.  If there are no spare User licences available but there are Read-Only 
User licences, a new user will only be able to open a database if he uses a read-
only user profile. 

Combining multiple licences 
You can install several licences on the same Cardbox Server, and the number of 
users will be added together.  For example, adding a 3-user User licence, a 10-user 
User licence, and a 10-user Read-Only User licence will result in a Cardbox Server 
that can accept up to 13 simultaneous users plus a further 10 who are only using 
databases in a read-only mode. 
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Professional Edition licences 
Strictly speaking, the Professional Edition licence belongs to Cardbox rather than 
the Cardbox Server.  Nevertheless, you can install this licence into the Cardbox 
Server instead of into Cardbox.  If you do this, the Cardbox Server will treat it like an 
ordinary User licence and it will increase the number of users who are allowed to 
connect to the Server.  You must not install the same licence on both Cardbox and 
the Cardbox Server. 

Setting up a licence server 
(This is a specialised feature and not everyone will find it relevant). 

The commonest arrangement for licensing Cardbox has the licences stored in files 
that are accessible to the Cardbox program.  On a network, these licences are 
stored in a shared directory that is accessible to all Cardbox users.  If you set things 
up like this then the Cardbox Server is not involved in licensing. 

If you are dealing with Professional Edition licences, you can also organise things 
another way: 

1. Install the Professional Edition licences on the Cardbox Server, using the 
Licences page. 

2. Tell the Server that it is allowed to lend these licences.  To enable licence 
lending, turn on the option “Lend Cardbox Professional licences to clients who 
have no licence” in the Licences page. 

3. On each user’s computer, install Cardbox without any licence at all.  During the 
installation process, tell Setup that Cardbox should attempt to borrow a licence 
from the specified Cardbox Server. 

4. Each time someone runs Cardbox, it will contact the Cardbox Server and ask to 
borrow a licence.  If it succeeds, it will behave just like any other Professional 
Edition copy.  If it fails, it will behave like a Client Edition: in other words, 
databases on the user’s own computer will be restricted to read-only access. 

The main advantage of setting licensing up like this is that you don’t need to set up 
any shared directories to store the Cardbox licences: indeed, it is possible for 
someone working at home on an Internet connection to borrow a Professional 
Edition licence whenever necessary.  

• Until it is borrowed, any Professional Edition licence on the Cardbox Server 
continues to count as an extra User licence, just as if licence lending had never 
been set up. 
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Loan codes 
You may not want everyone who can connect to your Cardbox Server to be allowed 
to borrow licences.  To restrict licence lending, turn on “Require a code before 
lending a licence” and type a code into the Valid Codes box. Codes can contain 
alphabetic or numeric characters: ABCD and 124JXZ are both valid codes. 

Each user’s Cardbox then needs to be configured (in the appropriate Setup page) to 
present the same code to your Cardbox Server when it tries to borrow a licence. 

You are allowed to enter more than one code into the Valid Codes box: separate 
them with spaces, not with punctuation.  In this case the Cardbox Server will accept 
any of those codes as being valid.  You could, for example, decide to give a different 
code to every potential borrower, and if you then wanted to prevent one of those 
people from borrowing a licence, you would only have to edit “Valid Codes” to 
remove that user’s code. 

 





 

 

Part Three 
Sharing databases 

How to make databases available for users to share; 

using the automatic directory; creating databases. 
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The Files page  
The Files page of the Cardbox Server control allows you to specify the databases 
that users can access on the server.  Any changes you make won’t take effect until 
you press OK.  If you change a database’s filename or make it inaccessible, this 
won’t affect any user who already has that database open. 

 
At the top of the Files page you’ll see a list of databases. These are shown in the 
order in which users will see them in the File > Open » Server command.  You can 
sort the list into sequence by clicking at the top of the relevant column or you can 
move an individual entry by highlighting it and then using the up and down arrow 
buttons just below the list. 

Attributes of each database 

Visibility 
A tick next to the name of a database indicates that it is visible in the list displayed 
by the File > Open » Server command.  If a database is invisible then a Cardbox 
user can still open it, by typing its name explicitly into File > Open » Server. 

For how to open the 
Cardbox Server control, 

see page 17.



    32  

 

Database name 
The database name is the name by which the database is known to users of 
Cardbox.  Database names are case-blind, so THINGS and Things are considered 
to be the same database name.  Database names may contain spaces but they 
cannot contain underline characters (“_”). 

Location 
The location is the actual filename of the database file (filetype .fil).  It is used by 
the server only and is invisible to Cardbox users. 

The filename is interpreted by the Cardbox Server while it is running, so (for 
example) C: refers to the C drive of the computer that is running the Cardbox 
Server.  This is an important point if you are running the Cardbox Server control 
remotely: do not confuse your own C drive with the C drive of the server!  See page 
“Finding out the name of an existing file “ (p.33) for more information. 

Comment 
This is ignored by the Cardbox Server and is there solely for your own information 
while you are manipulating the list of databases. 

Disabled entries 
Sometimes you may want to disable some of your database entries without deleting 
them – perhaps when testing a new configuration.  Disabled entries are shown in 
grey in the list of databases on this page, and they are ignored by the Cardbox 
Server. 

Using the Files page 
To add an existing  database to the list - press the Add button and type the name 

of the new database.  You will then be returned to the database list and you can 
set the database’s other attributes. 

To create a new database – see page 36. 

To remove a database from the list – click on the database entry to highlight it and 
then press the Delete button.  This doesn’t delete the database files themselves, 
only the database entry that tells the Cardbox Server which file to use. 

To change the attributes of a database – click on the database entry to highlight it 
and then use the boxes and buttons below the list to change whatever needs 
changing.  Note that if you want to change the database name then you will have 
to press the Rename button. 
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Finding out the name of an existing file 
If you have been used to opening a database from your workstation by using File > 
Open » My Computer and a network link (or if you have been using Cardbox 2.0 or 
earlier) you’ll probably have been using a filename that looks something like 
N:\path\filename.fil.  This won’t be a suitable name to put into the Cardbox 
Server’s file list, because it refers to a network drive.  Here is how to decode a 
network filename into a real filename on the Cardbox Server. 

Decoding the drive letter 
Suppose you have a network drive called N: on your computer.  Here are three 
ways of finding out what it really means. 

• Look at the list of drives in Windows Explorer. It will report something like 
“mydata on ORANGE (N:)” (this is just an example: your names will be different). 

• In Windows Explorer, use the command Tools > Map Network Drive and find 
drive N in the list – you will see something like \\ORANGE\mydata.  A name in 
this form is known as a UNC name. 

• In a command prompt window, type the command NET USE.  This will list all the 
drive letters together with their “remote name”, which will again give you the 
UNC name of the network drive. 

Decoding the UNC name 
The UNC name of the network drive looks something like \\ORANGE\mydata.  
This says that the computer on which the resource is stored is called ORANGE, and 
the name of the resource is mydata. 

Assuming that your server computer really is called ORANGE, you’re nearly there: 
all you need to do is find out what directory on the server corresponds to the 
mydata resource. 

On the server (not on your workstation), open a command prompt and type the 
command NET SHARE.  This will list all the shared resources together with the real 
name of each resource.  You might find, for example, that mydata corresponds to 
C:\Shared Documents\Example.  

Putting it all together 
So, assuming that everything matches this example, here’s an example of how 
you’d get the real server-based name of a file. 

Name viewed from the workstation: N:\Cardbox\myfile.fil 

UNC name: \\ORANGE\mydata\Cardbox\myfile.fil 
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Real name: C:\Shared Documents\Example\Cardbox\myfile.fil 

This real name is the name you will need to put into the Files page of the Cardbox 
Server control if you want to share this database using the Cardbox Server. 

You may wonder why we don’t provide you with a simple tool for finding out server-
based filenames instead of making you go through all these steps.  The reason is 
that two different computers are involved.  Your own workstation is the computer 
that translates the network drive letter into a UNC name, and the server is the 
computer that translates the UNC name into a real directory name – so there is no 
one place where all the information is available at the same time.  
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The automatic directory 
The automatic directory is a simple way of sharing a whole collection of files at once.  
If you give the Cardbox Server an automatic directory, it will create a database name 
for each filename in that directory, and it will add those database names to the list 
that Cardbox then displays in File > Open » Server. 

The automatic directory is simpler to use than the Files page but it is less powerful: 
you can’t control the database names (they are deduced automatically from the 
filenames) and all the names are always visible to Cardbox users. 

If a database name appears explicitly in the list in the Files page and the same 
database name is also deduced from a filename in the automatic directory, it is the 
definition in the Files page that wins: this is because we reckon that something you 
specify yourself by hand should take priority over something generated by an 
automatic process. 

Filenames with underlines in them (“_”) won’t be included in the automatically 
generated list: this is because database names aren’t allowed to contain underlines. 

To set up an automatic directory, use the options in the Server page. 

1. Turn on the Automatic Directory option 

2. Press the Browse button and navigate to the directory you want to use as the 
automatic directory. 

If you want to allow users to create databases in the automatic directory: 

1. Turn on the Allow Users to Create Databases option. 

2. If you want users to have to enter a password before they can create a 
database, enter the password into Password for Database Creation. 
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Creating a new database on the server 

Using the Files page 
1. Press the Add button to add a new entry. Give the database whatever name you 

want.  Make the database visible or invisible, whichever you prefer. Enter the 
filename that you want the database file to have.  Windows will warn you that the 
file does not exist and ask if you want to create it: say Yes. (The database file 
won’t actually be created until step 3). 

2. Press OK to close the Cardbox Server Control and save the changes you have 
made. 

3. Now, in Cardbox, use File > New Database » Server.  If you made the database 
visible, you can pick its name from the list; otherwise you will have to type in the 
name.  You will now have a blank, newly created database, just as you would if 
you were creating a database on your own computer. 

Using the Automatic Directory option 
1. Turn on Allow Users to Create Databases.  Save this change by pressing OK. 

2. In Cardbox, use File > New Database » Server.  Type in the name of the 
database you want to create. 

You can password-protect this process by entering a password in step 1, in which 
case Cardbox will ask for a password in step 2.  This lets you control which users 
are allowed to create databases. 

 

See page 31.

See page 35.



 

 

Part Four 
Security and administration 

Controlling access to administrative features, profiles 

and encryption; backup and download; the log file. 
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The Admin page 
This page controls miscellaneous settings to do with server administration.  

 

Controlling file lists from a client 
Cardbox has a command, Tools > Management > Server Administration,  that allows 
the user to control the Cardbox Server’s file lists directly.  This can be very useful if 
the Cardbox Server is running on a remote server that isn’t otherwise accessible, but 
it is a powerful command and not everyone should be allowed to use it. 

• To permit the use of this command, think of a password and type it into the Tools 
> Management > Server Administration Password box in the Admin page.  
Anyone who uses Cardbox’s Tools > Management > Server Administration 
command will have to enter this password before being allowed to do anything. 

• To prevent the use of this command, leave the Password box blank. 
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Performing backups 
In a large corporate network you may not be able to find a time when you can 
guarantee that no-one is using a Cardbox database.  Standard backup methods 
work only if the file you are backing up is not currently in use, and even those 
backup programs that have special provision for backing up busy files will only be 
able to back up what is actually in the disk file at the time of the backup: this can 
cause trouble if someone is making changes to a database because not everything 
will necessarily have hit the disk at the time the backup is done. 

Cardbox offers two solutions to the problem of backup.  Because they are 
implemented by the Cardbox Server, both solutions produce backups that are valid 
copies of your database files – if an update occurs while a file is being backed up, 
the backup will either include or not include the update: it will not be in some weird 
half-way state. 

Using a web browser 
You can connect to your Cardbox Server using a web browser and request a backup 
from there.  Here are some example of the address that you need to connect to from 
your browser: 

• If your Cardbox Server is running on a computer called myself, the 
address is http://myself:3105/backup.htm. 

• If it is running on a computer with IP address 127.0.0.1, the address is 
http://127.0.0.1:3105/backup.htm. 

When you open this page you will see a backup form, which asks you for the name 
of the database: this is the name as seen by Cardbox users, not the actual filename.  
It also asks you for the filename to which the database should be copied: this is the 
full filename of the intended backup file including any necessary drive and directory 
names.  No file should already exist with this filename: to avoid accidents, the 
backup function refuses to overwrite existing files. 

When you press the Perform Backup button, the Cardbox Server will make a copy of 
the database file and then display a confirmation page. 

Two settings on the Admin page of the Cardbox Server Control determine who is 
allowed to perform a backup using a web browser: 

From IP Address – if you type an IP address in this box, anyone connecting from 
that IP address will be allowed to perform backups.  If you type 0.0.0.0, 
anyone from any IP address at all will be allowed to perform backups. 

Username:password – you can type a user name followed by a password into this 
box.  For example, typing cat:mouse will give a user name of cat and a 
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password of mouse.  When you connect to the backup page, your web browser 
will ask you for a user name and password before the page can be opened. 

Only one of these tests needs to be successful before the backup page will open.  
The most common configurations are: 

IP Address blank, username:password blank: the backup page can never be 
opened. 

IP Address set to a value, username:password blank: only someone from the 
specified IP address can open the backup page. 

IP Address blank, username:password set to a value: the browser will always ask for 
a user name and password and needs a correct entry before it will open the 
backup page. 

IP Address set to a value, username:password set to a value: someone from the 
designated IP address can open the backup page at once without any further 
formalities; other users have to enter a user name and password. 

Downloading backup copies 
An alternative backup that requires no server configuration at all is to run Cardbox, 
open the database, and use the Tools > Management > Download command.  This 
copies the file to the computer that is running Cardbox: this will be a valid file even if 
the Cardbox Server was halfway through doing an update. 

Tools > Management > Download allows you to overwrite a file.  In fact, the most 
efficient setup is to download repeatedly onto the same file on your PC, because the 
Download command can check your PC’s file against the file on the Cardbox Server 
and download only the parts of the file that have changed since the last download. 

The useful thing about this method is that it results in a copy of the server database 
being stored on your own computer.  Even if you are sluggish about backing up your 
computer, having a copy of the database in two places already adds some security. 

• If user profiles are set up for a database, Tools > Management > Download can 
only be done by using the master profile. 

Backing up encrypted databases 
An encrypted database can be backed up like any other: Cardbox makes no 
distinction.  The backed-up copy of the database is, of course, encrypted as well, 
just like the original. 
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The Security page 

 

Controlling setup of user profiles 
Setting up user profiles is a powerful and potentially dangerous activity.  If access to 
the feature were not controlled, an enemy could cripple you simply by opening your 
database and giving it a master password that only he knows (master passwords 
can be reset but the process is slow and expensive).  Accordingly, when you set up 
a database’s user profiles for the first time, Cardbox asks for an access code. 

Access codes are derived from the serial number of the running copy of Cardbox, 
and they can be obtained from us on request when you register Cardbox: for 
security, access codes are sent by post directly to the registered user. 

The approach described above is valid for databases created on the user’s own 
computer, but things aren’t as simple if a database resides on a Cardbox Server and 
doesn’t yet have a master profile.  Requiring an access code for Cardbox itself 
wouldn’t be much protection (because a determined enemy would get hold of a copy 
of Cardbox whose access code he knew), and so the Cardbox Server offers three 
alternatives: 
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Use the Server’s Built-In Access Code requires the access code that you received 
when registering the Cardbox Server. 

Use a Specified Access Code requires an access code that you specify.  If you 
suspect that the access code has been revealed then you can always change 
the access code. 

Don’t Accept Access Codes means that no-one can set up user profiles for this 
database while it is on the Cardbox Server.  If you want to set up user profiles, 
you will have to copy the database to your own PC, set up profiles there, and 
then upload the altered database to the Cardbox Server. 

Controlling use of encryption 
Encrypting a database is a radical act and if the key is forgotten or deliberately 
destroyed then your data will be useless.  Cardbox protects you as best it can, by 
demanding the password of the master profile (or the access code, if no user 
profiles exist) but the Cardbox Server can provide an extra level of protection.  If you 
turn on Do not Allow Unencrypted Databases to be Encrypted, the Cardbox Server 
will simply refuse to encrypt any database that isn’t already encrypted.  Changing 
encryption keys or removing encryption are still permitted. 
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The Log page 
Sometimes mysterious things happen and you ask us for help.  We, in turn, need to 
know what has been going on, and one of the ways of doing this is to get the 
Cardbox Server to write a log file.  The log file will list various events and will enable 
us to give you better support.  Don’t set anything in this page unless we ask you to. 

 
If it becomes necessary to write a log, we will tell you which settings we want you to 
make. 
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Upgrading from Cardbox 2.0 

How Cardbox 2.0 worked 
Cardbox 2.0 (and earlier versions of Cardbox and Cardbox-Plus) used the following 
system for sharing databases on a network: 

• A single control file called CARDBOX.SHR coordinated the use of Cardbox as a 
whole. 

• For each shared database, a control file of filetype .LOK coordinated the use of 
the database. 

Consequences of this setup included: 

• All Cardbox users had to have read/write access to CARDBOX.SHR. 

• All Cardbox users had to have read/write/create access to directories that 
contained databases, so that they could create and write to the .LOK file. 

How Cardbox 3.0 works 
With Cardbox 3.0, file sharing has been replaced by a client-server architecture.  
The Cardbox Server runs on one computer on the network and provides shared 
database services to all Cardbox users. 

• CARDBOX.SHR is no longer needed. 

• .LOK files are no longer created.  Cardbox users do not to have access to any 
shared directory. 

A simple strategy for conversion 
This is not the only way of converting your network from the old style to Cardbox 3.0, 
but it has been designed to be quick and simple to implement. 

1. Perform an audit to see what shared databases exist.  Move them so that they 
are all on the same computer, in a directory that is not shared on the network. 

2. On this computer, install the Cardbox Server. 

3. Set the Automatic Directory to be the one containing the shared database files. 

4. Set the Cardbox Server to run automatically when the computer starts. 

5. Install the Cardbox program files, along with the multi-user Professional Edition 
licence, in a shared directory on the network.  This can be on the same 
computer that is running the Cardbox Server, but it doesn’t have to be. 
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6. To give a workstation user access to the Cardbox database files, use Windows 
Explorer to navigate to the shared directory and then double-click on 
CARDBOX3.EXE. 

Separate installation on each computer 
A variant is possible if you prefer to have programs installed on each workstation 
rather than centrally (either because it is company policy or because the network is 
unacceptably slow).  Steps 1 to 4 are the same.  Then: 

5. Designate a shared directory to hold the licence data. All Cardbox users will 
need read-only access to this directory. 

6. Choose a workstation. Temporarily give it read/write access to the shared 
directory. Install the Cardbox program files on one workstation, and as part of 
the Setup process, tell Cardbox to store its licences in the shared directory. 

7. To give a workstation user access to the Cardbox database files, install Cardbox 
on the workstation and tell the Setup program the name of the shared directory 
where the licence is stored. 

Opening databases 
Previously, users will have been accustomed to using File > Open and navigating to 
the directory that contains a shared database. 

With Cardbox 3.0, users should use File > Open » Server, select the name of your 
server from the list (or type it in if it is not listed), and then pick the database they 
want from the list that appears. 

There are other differences between Cardbox 3.0 and earlier versions, but these 
have nothing specifically to do with networking and you will find them listed in the 
appendix of The Cardbox Book. 
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A brief introduction to TCP/IP 
This section is quite technical but you almost certainly won’t need to read it in any 
detail unless you have an unusual configuration or unusual problems.  

TCP/IP 
TCP/IP was first developed for use on the Internet but nowadays most Windows 
networks use it as well: if yours is an old network that does not have TCP/IP set up, 
you can install it using the Networking control in the Windows Control Panel. 

TCP establishes a reliable connection between two computers: “reliable” in the 
sense that data won’t be corrupted or go missing, although if the connection is 
broken altogether then communication between the two computers will end. 

Identifying computers 
When you are in Cardbox and you use File > Open » Server to open a Cardbox 
Server, you need to tell Cardbox which server to connect to, by entering the server’s 
domain name or its IP address.  When you are setting up a Cardbox Server, you 
therefore need to have at least one of these pieces of information so that people 
who want to connect to the server know what to type. 

Domain names 
Normally, every computer on a network has a name that identifies it uniquely on that 
network.  On the Internet, these addresses come in several parts separated by dots, 
like www.cardbox.com; on a LAN, they will be simpler, often just one word like 
JUNO or LIBRARY, since the name only has to be unique on this one network. 

When you’ve decided which computer to use for the Cardbox Server, ask your 
system administrator what the name of that computer is.  If you are your own system 
administrator and you are running Windows, you can use the Computer Name page 
of the System Properties window to tell you the computer’s name. 

IP addresses 
If using a domain name doesn’t work for some reason, you can tell Cardbox to 
connect to a server by using its IP address.  An IP address is the computer network 
equivalent of a telephone number, and it is usually written as four numbers 
separated by dots: for example, 212.23.248.33.  The translation from domain 
names to IP addresses is normally automatic, but if something isn’t correctly set up 
with the domain name system in your network, the translation may fail. In that case, 

TCP = “Transmission 
Control Protocol”.

IP = “Internet Protocol”.

LAN = “Local Area Network”.
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using the server computer’s IP address is a quick way to get things working until the 
underlying problem is resolved. 

Discovering a computer’s IP address 
Your system administrator should know how to get the IP address. Otherwise, in 
Windows, you can do the following: 

1. Within “Network Connections”, right-click on the connection you’re interested in.  
If you have several network connections then make sure you choose the one 
that people will be connecting to you on, because your computer may have a 
different IP address when viewed from different connections. 

2. Select “Properties” from the menu that pops up. 

3. In the Properties window, select the General tab. 

4. In the list, select “Internet Protocol (TCP/IP)”, then press the Properties button. 

5. In the Internet Protocol (TCP/IP) Properties window, look at the setting. If “Use 
the following IP address” is turned on, you will see the IP address just below it; if 
“Obtain an IP address automatically” is turned on, then you have a “dynamically 
allocated” IP address, which means that it may change from time to time.   

Remember to do all this on the computer that is running (or going to run) the 
Cardbox Server, not on your own computer; otherwise you’ll end up getting your 
own computer’s IP address! 

The trouble with dynamically allocated IP addresses 

If you have a dynamically allocated IP address then this means that the IP address 
may change every time your computer starts up and connects to the network.  This 
makes it impractical for Cardbox users to use IP addresses to connect to the 
Cardbox Server, and you should stick to domain names. 

If you are trying to make databases available across the Internet, and your Internet 
connection has a dynamically allocated IP address, then you have a problem.  Ask 
your ISP about getting a statically allocated IP address, or look up “dynamic domain“ 
in a Web searcher to find out about services you could use to set up a domain name 
that will always point to your computer. 

Loopback 
When you’re setting up and testing a Cardbox Server, it is often useful to run 
Cardbox on the same computer, just to see that everything is working. 

The special domain name “localhost” always refers to the computer you’re on – so 
when you want Cardbox to connect to the Cardbox Server on the same computer, 
just use the server name localhost, or its IP equivalent, which is 127.0.0.1. 

ISP = “Internet Service 
Provider”.

These instructions are for 
Windows XP.  Different 

versions of Windows have 
slightly different ways of 

getting at this information: 
consult your system 

documentation for details.
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Firewalls 
The purpose of a firewall is to control TCP/IP communications and one of the 
commonest ways in which it does this is by inspecting each incoming or outgoing 
connection request and checking the port number that it is using (port numbers 
identify what program the request is intended for). The idea is that you can then 
block all connection attempts except those that you know are legitimate. 

• If you have a firewalled system and want to run the Cardbox Server, ensure that 
the firewall has opened port 3105 for incoming TCP connections. 

• If you have a firewalled system and want to use Cardbox to connect to a 
Cardbox Server elsewhere, ensure that the firewall has opened port 3105 for 
outgoing TCP connections.   

The Windows Firewall 
The version of the Windows Firewall included with Windows XP Service Pack 2 will 
pop up a message when you first run the Cardbox Server.  Tell it that you want to 
allow incoming connections, and it won’t bother you again. 

This version of the Windows Firewall doesn’t monitor outgoing connections, so you 
don’t need to do anything special when using Cardbox to connect to a Cardbox 
Server. 

Virtual private networks 
Virtual private networks (VPNs) are an exception to much of what we will be saying 
about LAN and Internet connections.  If you have a VPN, it will make your 
computers look as if they’re on the same LAN even if they happen to be in different 
cities; and although it may well use the public Internet to transmit data from one city 
to another, this fact will be hidden from the computers on your network and the data 
will be encrypted so that outsiders cannot breach your privacy. 

In the remainder of this book, whenever we talk about a local area network, we 
effectively mean “a LAN or a VPN”, and we won’t consider a computer that has a 
VPN connection as really being connected to the Internet at all. 
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The Cardbox Server under Linux 
The Cardbox Server is available for Linux as well as for Windows.  All the principles 
of operation are the same but the details are different, mostly because the Linux 
version uses configuration files directly instead of hiding them behind a control in the 
Windows control panel. 

Installation 
The full instructions for installing the Linux version are on the Cardbox web site and 
are accessible from the Linux version’s download page.  Here is a summary of the 
steps that you need to go through: the actual filenames may be different from the 
ones shown here. 

Choose the directory where you want to install the Cardbox Server, and create it if 
necessary.  The directory name you choose will depend on the conventions that you 
are using, but we will use /home/cardbox as an example.  

Change to the directory you have chosen. 

Download the program file cshared.tar.gz from the Cardbox web site. 

Enter the command 

  tar –xzvf cshared.tar.gz 

tar will report the program name (cardbox-shared) as it decompresses it. 

You can now delete cshared.tar.gz because you have no further need for it. 

Inserting licence details 
Create a text file called licence.ini in the same directory as cardbox-
shared.  You can do this using cat or vi or your favourite text editor.  We will give 
you the licence details that you need to put into this file, but here is an example of 
the format: 

[Cardbox] 
Signature = 3967-2Y47-6739-55X0 
Users = 0 
Type = 4 
Serial Number = 0000000 
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Removing the Cardbox Server 
There is no automated removal process for the Linux version.  Simply delete all the 
program files and the /home/cardbox directory. 

Configuration 
There is no Cardbox Server Control in Linux, so all configuration has to be done by 
editing the configuration file server.ini, which is located in the same directory as 
cardbox-shared.  You can do this using cat or vi or your favourite text editor. 

The general format of server.ini is that of a Windows .ini file.  It is divided into 
sections, marked by a section name in square brackets, and within each section 
there are values listed, each with a name, an equals sign, and a value.  Here is an 
example: 

[Server] 
Access = RW 
Log = 9 
Description = Our own local Cardbox server. 
[Debug] 
LogMask1 = -1 
LogMask0 = -2 

Blank lines are allowed for clarity, and a semicolon can be used to indicate that the 
rest of a line is a comment. The main thing to be aware of is that each section name 
should only appear once, or the Cardbox Server cannot be guaranteed to read all 
the values correctly. 

For a full listing of the possible entries in server.ini, see the Cardbox web site. 

Notifying changes in server.ini 

Under Linux, the Cardbox Server doesn’t automatically detect changes in server.ini. 
To notify it of a change, send it the HUP signal.  Use ps or ps –a to find out the 
process ID of the Cardbox Server process and then use kill –HUP to send the 
signal to that process. 

www.cardbox.com/linux.htm
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Starting and stopping the server 

Starting the Cardbox Server 
Change to the directory containing the Cardbox Server and use the command 

./cardbox-shared –d 

to start the Server as a daemon. 

If you omit –d, the Cardbox Server will run interactively, logging all its activity to the 
console: in this case you can stop it by typing Ctrl+C. 

Stopping the Cardbox Server 
First see if the Cardbox Server is running and find out what its process ID is.  For 
example: 

ps –a | grep cardbox 

will report the process ID of the Cardbox Server if it is running. 

Then use kill with the process ID to ask the Cardbox Server process to stop.  This 
can take a few seconds because the Server may have to write unwritten data to the 
disk. 

It is not always possible to start the Cardbox Server immediately after stopping it, if 
there were some active connections to clients when you stopped the Server.  This is 
because some of these connections may persist for a while (you can use netstat 
to see them) and until they have all timed out it will not be possible for the newly 
started copy of the Cardbox Server to listen for new connections. 

Starting and stopping the Cardbox Server automatically 
We do not supply startup or shutdown scripts for the Cardbox Server because Linux 
distributions vary in the way they organise their rc.d files, but if you have some 
experience of shell programming then it is possible to create your own.  You have 
seen how to use ps to determine whether the Cardbox Server is already running, so 
your startup script can exit immediately if this is the case.   

As for shutdown, the script can automate the manual procedure shown above, but it 
should then wait for the Cardbox Server process to terminate so that system 
shutdown does not happen while the Server is still writing data to the database files. 

 


