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Getting Started 
Cardbox is a flat-file database program.  It lets you design your own databases, so you 
can make them hold anything – people’s contact details, books, abstracts, photographs, 
biographies, CVs of job applicants, personal records, lists of stolen antiques, museum 
catalogues, contracts and official documentation, confidential accident reports, 
poisoning incidents.  Whatever it is, if you can make a list of it, you can organise it with 
Cardbox. 

 “Getting Started” will help you learn your way around Cardbox: 

• If you have to find information in a Cardbox database. 
• If you’re thinking of buying Cardbox. 
• If you’ve bought Cardbox but don’t want to open the book just yet.  

We have divided “Getting Started” into four parts: 

1. Viewing, browsing, searching, printing, etc. 

2. Images, photographs, and documents. 

3. Adding and editing records (including automated batch-editing). 

4. Designing your own formats and databases. 

What you need 
You need Cardbox. For the first two parts of “Getting Started” any old version of 

Cardbox will do, even the freely downloadable Client Edition. When you get on to 
adding and editing records and designing your own formats, you’ll need a licence of 
some kind – either a full licence or a time-limited evaluation licence. 

You need the sample databases. “Getting Started” talks you through Cardbox by using 
these databases. You can download them or you can access them across the 
Internet, directly on our Cardbox Server. 

If you’ve installed Cardbox from the CDROM then you should already have everything 
you need. If you’re downloading Cardbox to try it out, see the Cardbox web site for what 
to download and how to arrange a trial licence. 

Getting more information 
At every stage of your guided tour through Cardbox you can take side trips of your own. 
Explore the menus, look at the commands and try them out.  One of the best tools to 
help you do this is the Cardbox help system. 

F1 = Help 
Wherever you are in Cardbox, you can press the F1 key.  The help file will open and 
show you a page relevant to where you currently are.  If you’re in the middle of a 
command, it will give you help on that command; if you are editing a format, it will tell 
you all about editing formats. 

Getting help on menu commands 
When you open a menu and move your mouse over the various commands, watch what 
happens to the status bar at the bottom of the Cardbox window.  As you move over a 
command, the status bar will show a brief explanation of what the command does.  If 
you want more information, press F1 while you still have the mouse over the command. 

Help Points 
As you read through this book, you’ll see references to “Help Point” and a number.  Help 
Points are help file articles that give you more details on something the book is talking 
about: in many cases they also have links to other parts of the help file.  To view a help 
point, use the command Help > Help Points and then type in the number of the help 
point. 

References to Help Points 
usually appear in the 

margin.

If a menu command is 
disabled, move the mouse 
onto it and wait a moment.

Cardbox will explain why the 
command isn’t available.

www.cardbox.com
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Starting Cardbox 
You can start Cardbox by opening a Cardbox icon from the Start menu or the Windows 
desktop. You can also start it automatically by double-clicking on a database file. 

Opening a database 
How you open a database depends on where it is.  In “Getting Started”, we’ll be dealing 
with sample databases that have been downloaded to your Sample folder, or sample 
databases on our Cardbox Server. 

Databases in your Samples folder 
Use File > Open and then go to the “Samples” tab. If you downloaded the sample files 
somewhere other than Cardbox’s Samples folder then you won’t see a Samples tab: use 
the “My Computer” tab instead. 

Databases on our Cardbox Server 
Use File > Open and then go to the “Servers” tab. If database.cardbox.net isn’t 
already highlighted then double-click on it and you’ll see a list of available databases. 

 

Opening several databases at once 
There is nothing to stop you having more than one database open at the same time, and 
it’s often a very useful thing to do. Each database gets opened in its own window within 
the main Cardbox window. The Window menu lets you control these windows and 
switch between them. It also lets you decide if all the database windows should be 
visible together within the Cardbox window or whether you just want to see one 
database window at a time. 

Advanced feature: workspaces 
When you close Cardbox and re-open it again, it will re-open all the databases that were 
open before you closed Cardbox, so you can carry on exactly where you left off. 

This collection of open windows and files is called a “workspace” and if you are using 
Cardbox for several different projects then you can create a separate workspace for 
each project, open selected workspaces, and switch between them. 

Keyboard shortcut: 
Ctrl + F6 takes you from 
one database window to 

the next.

More information: do 
File > Workspace and 

then press F1.

File > Open 
Ctrl + O 
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The Contacts database 
We’re going to start by opening the sample Contacts database. Here it is: 

 
We have designed this database as an example of how you might use Cardbox for 
contact management. Even if you have some completely different purpose in mind for 
Cardbox, the basic principles of operation are always the same and you’ll learn a lot 
about Cardbox just by following our tour through the Contacts database. 

Nothing about this database is compulsory. This is simply a database that we have 
designed as an example, to illustrate Cardbox’s features and give us something to build 
a “Cardbox tour” round.  Everything about it is our own choice, from the colour scheme 
to the number of fields and their size and shape.  

Your choices may be different. When you come to design your own databases you are 
completely free: you can design a database for any purpose, not just contact 
management. You can copy any ideas that you like and ignore the others.  

Indexed text 
You’ll see that some words are displayed in bold text. This means that they have been 
marked for indexing.  Cardbox’s indexing is what makes it so fast: when you search for a 
word, Cardbox looks it up in its index rather than having to scan through every record in 
turn. We’ve chosen to have indexed terms displayed differently from unindexed ones 
because we find the database easier to use that way; if you don’t agree with us, you can 
choose to have unindexed and indexed text looking identical in your own designs. 

An important feature of Cardbox is that you can have several terms indexed in each 
field. This sets it apart from most other mainstream database programs. You can have 
every word indexed in a field, or you can put indexing under manual control so that 
some terms in a field are indexed and others aren’t: this is what lets you say “Anthony 
Alcott” where other programs would insist on “Alcott, Anthony” or on splitting the name 
into two or three separate fields. 

Finally, note that when we say “words” we really mean “words, numbers and dates”. 
Cardbox recognises numbers and dates by looking at them, and indexes them 
appropriately. 

Check boxes and radio buttons 
You’ll see that the “Products of interest” field has a set of check boxes rather than just a 
space for typing text. This is a powerful feature of Cardbox that you can apply to any 
field: it ensures that only specific codes are entered into the field, and it lets you enter 
them with just a mouse click. You decide what fields should have check boxes, and what 

On the screen, these bold 
words are displayed in red.

You decide the indexing 
policies for each field when 
you design your database.
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the codes should be, when you design the database. You can always change your mind 
later and add new codes if you need them. 

Radio buttons work much like check boxes except that they only allow a single option to 
be chosen. In addition to check boxes and radio buttons, Cardbox also lets you display a 
field as a drop-down list, from which you can select a single item when you are entering 
data into the record. 

Extra Text 
At the bottom of the Contacts screen display you’ll see a horizontal line with some text 
below it. This is the Extra Text field. 

The Extra Text field is optional. If you decide to have one, it behaves like a sheet of 
paper pasted to the back of an index card: it can contain as much text as you like and it 
can be viewed and printed together with the main record or separately. Extra Text can’t 
be indexed but it can be searched using Cardbox’s Search > Data menu. 

We won’t talk about Extra Text again in this “Getting Started” – the Cardbox books give 
more information, and so does the on-line Help. If you can’t think of a use for Extra Text, 
just forget about it: after all, Cardbox’s normal fields can be huge and can store a large 
amount of text in any case. 

Some other database 
programs have a “Memo 

field” that works much like 
Extra Text.
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Browsing through records 
At the bottom of the Cardbox screen you’ll see  a display in the status bar telling you 
you’re on the first record. Press the right-arrow key and you’ll move to the second 
record; press it again and you’ll move to the third. 

We call this simple stepping through records “browsing”. It’s something that you will do 
time and time again – usually after making a selection of records, but you can do it at 
any time that Cardbox is showing you records on the screen, even before you have 
entered any selection commands. 

Browsing with the browse bar 
If you look at the bottom of the Cardbox window you’ll see what looks like a scroll bar 
with corrugations.  This is called the browse bar.  It tells you which record you’re looking 
at and how many records there are in the current selection. 

 

Browsing with the keyboard 

Right arrow 

Down arrow 
Next record. 

Left arrow 

Up arrow 
Previous record. 

Ctrl + Home First record. 

Ctrl + End Last record. 

Ctrl + G A specified record number.  Cardbox 
will ask you which record number you 
want. 

Ctrl + Z The record you were on just before the 
last big jump (Ctrl + Home or 
Ctrl + End) or the last search 
command.  

Page Down Go forward 
one page in 
the list. 

Page Up Go back one 
page in the 
list. 

Home The top 
record on this 
page. 

End The bottom 
record on this 
page.  

The current record 
Whenever you look at a Cardbox database, one record is the current record: if you tell 
Cardbox to edit, this is the record that will get edited; if you tell Cardbox to delete a 
record, this is the record that will get deleted.  If the screen is only displaying one record, 
that’s the current one; if the screen is displaying a list of records, Cardbox draws a thin 
black frame round the current record so you can see which one it is.  

If your records are small 
enough for Cardbox to 
display them as a list, 

you’ll get an additional  
browse bar, placed 

vertically next to the list.  



    6  

Formats and appearance 
A format is what gives shape to your data.  It is everything you see on the screen when 
you look at a record, except for the actual data.  It covers the way your fields are laid out 
(and which ones appear at all), plus any captions, lines, boxes, and so on.  A Cardbox 
database can have as many formats as you like.  Some databases have one, others 
may have dozens. 

The native format – You’ve already seen the main format of Contacts: this was the first 
format we created and it’s the basis of all the others. Cardbox calls this first format 
the “native format”. 

One-line Summary – We’ve put this format in so that you get a simple summary of the 
currently selected records. We’ll use it a lot when taking you the searching facilities 
of Cardbox: because it’s only one line long, Cardbox can display many records on 
the screen at once and help you see where you are. 

 
Leads Summary – We’ve designed this format to show the fields that are most 

appropriate for analysing sales leads. 

 
Reps Summary – This format shows fields relevant to managing sales representatives. 

 
Label – The name and address of the contact, mail-merged into a suitable format for a 

mailing label.  When you are setting up 
the printing, you can tell Cardbox what 
size the labels are and how they are laid 
out on the page. 

 

 

Many database programs 
call this sort of format  

a “list view”.
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Demonstration letter - a mail-merged letter that pulls in fields from a record.  You can 
use this kind of format for personalised letters, individually or in bulk; for filling in the 
blanks in standard forms or contracts; or for emails or faxes.  Your Cardbox 
database can have as many different letter formats as you like.  

 

Exploring formats 
View > Change Format lets you switch to a different format.  It will show you a list of 
formats and you can do any of the following: 

• Type the name of the format and press OK. 
• Or select the format in the list.  You’ll see a description of the format at the bottom of 

the window (assuming that whoever designed the format gave it a description).  To 
use this format, press OK. 

• Or double-click on the name of the format in the list. 

When you first open a database, you will be viewing the data using the “native format”. 
The native format is the first format that you create for a database. It doesn’t have a 
name.  Try using View > Change Format to explore what formats are available in the 
sample database you have opened. 

Changing the appearance 
You can change the fonts, sizes, colours, backgrounds and line thicknesses that are 
used to display or print your data.  You can do this while you are designing a format, but 
you can also override the appearance at any time by using the command View > 
Appearance. 

 

We have made the fields 
blue so you can see 

where the data come 
from. A real letter would 

all be in one colour.

View > Change Format 
Ctrl + F 

View > Appearance 
Ctrl + A 
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Indexing 
To make searching faster, Cardbox creates an index of your database.  That way, 
instead of having to look through every single record to find the ones you’re looking for, 
Cardbox can look at the index and find what you want in a fraction of the time.  The 
bigger the database, the bigger the benefit. 

Indexing is something that all databases do to some extent, but here’s how Cardbox is 
different: 

• It can index every word, number, or date in a field. 
• Within a single field, it can let you choose which words (or numbers, or dates) to 

index. 

Unlike with many other databases, you don’t have to twist names round to fit the way the 
computer wants them – “Public, John Q.” – or even “John | Q | Public” in three separate 
fields.  You don’t have to have artificial fields (KEYWORD 1, KEYWORD 2, 
KEYWORD 3) or use sophisticated programming.  You just mark the words you want to 
be indexed, and Cardbox indexes them. 

For each field, you decide the indexing strategy at the time you design the field; 
although you can go back and change your mind afterwards.  The simplest indexing 
modes are All, which indexes everything in a field, and None, which indexes nothing.  
More interesting is Manual, which lets you mark individual words for indexing as you 
type them in (or you can go back and mark or unmark them later).  There is also Auto, 
which is rather like Manual backwards: everything’s indexed unless you tell Cardbox not 
to index it.  

You can tell Cardbox to display indexed words differently from unindexed ones. In our 
sample databases we usually do this, to make it clearer what is going on; but it’s not 
compulsory and for some purposes, such as printing, you’ll want to make indexed and 
unindexed words look the same. 

Date formats and Cardbox 
There are many different ways of writing dates.  Even the sequence of the components 
varies: ‘day, month, year’, ‘month, day, year’ and ‘year, month, day’ are all used in 
different parts of the world.  Because Cardbox databases can be international, Cardbox 
cannot deduce the date sequence from the location where you’re using it.  Instead, it 
looks at the way you typed the date: specifically, at the character that you used to 
separate the different parts of the date.  Here is the 19th of April 1962: 

Separator Format Example 

/ (slash) day/month/year 19/4/1962 

- (hyphen) month-day-year 4-19-1962 

. (decimal point) year.month.day 1962.4.19 

• The day and the month can be one or two digits long: 04 is the same as 4.  

• Cardbox identifies the date format by looking at the separator, so you cannot enter 
something like 4/19/1962 and expect Cardbox to handle it properly.  

When Cardbox indexes a date, it reshuffles it into a number, in a standard format.  All 
the date formats shown in the example above will be indexed as the same number, 
1962.0419.  This has the advantage that when records are sorted into numerical order, 
this will yield exactly the right date sequence as well.  

As a result of the way that Cardbox indexes dates, when you are previewing an indexed 
search, the preview listing will show all your dates as numbers.  

You can also set up 
“validators” which index 

selected words 
automatically without you 

having to mark them. 
Validators are part of the 

Professional Edition of 
Cardbox.
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Simple search commands 
To keep this description simple we’ll assume that 
you’re using our Contacts database; but if you are 
using another database then you can explore it in 
much the same way. 

Use View > Format to switch to the One-Line 
Summary format. 

The Select command 
Right-click anywhere in the Address column. A search 
window will pop up. Type the word London in the 
“Search for” box and hit Enter (or click on OK). 

Cardbox will search for records that have “London” 
indexed in the Address field.  It will show you all the 
records it has found, and you can use the keyboard 
and browse bar to browse among them. 

This is one of several ways of starting a search.  You 
can also use a menu command or a toolbar button to 
do the same thing. 

The Exclude command 
Go back to level 0, and do almost the same thing again. But this time, instead of right-
clicking in the Address column, depress the right mouse button and hold it down for a 
second or two. A menu will pop up with a list of commands: choose “Exclude” from the 
list.  A search window will pop up. Type the word London in the “Search for” box and hit 
Enter or click on OK. 

As before, Cardbox will search for records that have “London” indexed in the Address 
field, but this time it will discard those records from the current selection and show you 
the records that do not have “London” indexed in the Address field. 

Things you can search for 
So far you have searched your database for a single indexed word, but there are many 
other kinds of index searches. 

Wildcards 
When you type a word into “Search For”, there are two special characters you can use 
as wildcards: 

? matches exactly one character. 

* matches any number of characters (including zero characters). 

This can be useful if you want to capture a number of different spellings, or if you aren’t 
sure if a term was being used in the singular or the plural (HOUSE versus HOUSES) or 
if you’re in a hurry and don’t want to type the whole of a long and complicated word. 

Ranges of words 
You can put two words separated by a colon into the “Search For” box: 

E:K finds all indexed words beginning with a letter from “E” to “K” inclusive. 

:COB finds all words from the beginning of the index to the last word that starts 
with “COB”. 

XE:  finds all words from the first indexed word that starts with “XE” to the last 
word in the index. 

  

Searches behave the 
same way whatever 

format you are using, but 
this summary format will 

make it easier to see what 
records you’ve selected.

Before you start a simple 
search, always make sure 
that the status bar says 
“Level 0”, which means 
that Cardbox is showing 
you every record in the 
database. If you don’t do 
this, your search 
commands will go towards 
refining or revising the last 
search that you did. 

To get to Level 0, do 
Search > Clear All 
Selections, or hold down 
the Ctrl key and press the 
Undo button on the toolbar:

  Search > Select 

Search > Exclude 

If you’re not sure what 
words your wildcard will 

match, press the Preview 
button and Cardbox will 

show you a list.

Unlike numeric and date 
ranges, word ranges are a 

specialised feature and 
few people use them.
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Single numbers and dates 
To search for a single number or date, type it into the “Search For” box and press OK.  
For details of the date formats that Cardbox understands, see “Date formats and 
Cardbox”, above. 

Ranges of numbers and dates 
You can put two numbers (or dates) separated by a colon into the “Search For” box: 

17:32 finds any indexed number between 17 and 32, inclusive. 

14.6: finds any indexed number greater than or equal to 14.6. 

:30000 finds any indexed number less than or equal to 30000. 

: finds all indexed numbers. 

Phrases 
If you put a series of terms (words, numbers, or dates) in quotation marks, Cardbox will 
search for records that contain those terms adjacent to each other and in exactly that 
order.  It will only look at things that are indexed: unindexed text will be ignored. 

"RED DOG" will match BIG RED DOG but not RED BIG DOG. 

You can also search for words that are in a particular order but may have other words 
separating them, by using special search words. 

... (three dots) will match any number of words.  So "RED ... DOG" will match 
RED DOG, RED BIG DOG and RED BIG FIERCE DOG. 

* (asterisk) will match exactly one word.  So "RED * DOG" will match RED 
BIG DOG and RED LITTLE DOG but not RED DOG or RED 
BIG FIERCE DOG. 

There are more sophisticated options as well: for instance, you can search for two words 
that are not more than a certain distance apart. 

Lists 
You can type several terms (words, numbers, or dates) into the “Search For” box, 
separated by spaces.  What happens depends on the setting of the “Match All” option. 

With “Match All” turned off, Cardbox will find records that contain any of the terms you 
have typed: in Boolean terms, this means OR. 

With “Match All” turned on, Cardbox will find only those records that contain all the terms 
you have typed: in Boolean terms, this means AND. 

Some more examples: 

  
This is what we do when someone comes back from paying in cheques at the bank.  We 
open our Sales Ledger database, right-click on the Invoice Number field, and type a 
command like this one to find all the invoices whose cheques have just been paid in.  
You can see that the “Search For” box accepts ranges as well as single values. 

  
This is something we use when we need to find a user’s record but have nothing more 
than an abbreviated company name to go on.  It’ll find any record where the field 
contains a word beginning with S, a word beginning with V, and a word beginning with 
R, not necessarily in that order. 

For details, do Help > 
Help Points and choose  

Help Point 510.
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Boolean combinations (advanced searching) 
You can have more elaborate combinations of search terms than just “any” (OR) or “all” 
(AND), by using a few extra symbols: 

A plus sign + in front of a term means that that term must occur in any record that 
Cardbox finds: a Boolean AND. 

A minus sign - in front of a term means that that term must not occur in any record that 
Cardbox finds: a Boolean AND NOT.  [If you put this in front of a number, leave a 
space between the minus sign and the number, or Cardbox will think that you’re 
simply talking about a negative number]. 

Parentheses () round a group of terms means that at least one of those terms must 
occur in any record that Cardbox finds: a Boolean OR. 

You can combine these symbols in more or less any way you like.  For example, 
(HISTORY HISTORI*) +(INSTITUTE SOCIETY) would find records that had 
INSTITUTE or SOCIETY in them as long as they also had HISTORY, HISTORIAN, 
HISTORICAL, etc. 

If a search gets this complex then you may find it easier and clearer to build it up step by 
step, combining separate Select and Exclude commands instead of using a massive 
Boolean combination. The next section will tell you how to do this.   

Preview lists 
On the right-hand side of the Search command windows you’ll find two buttons, Preview 
and Preview-and-Count.  They almost do a search, but not quite.  Instead of finding 
records that match your command, the Preview buttons look through the index and find 
the index terms that match, and they present you with a list of them.  Here are some 
possible uses: 

• If you’ve put a wildcard into the “Search For” box, you can use Preview to work out if 
it’ll find what you want it to find. 

• If you’re not very familiar with the database you’re using, and you aren’t sure what 
values a field can contain, you can leave “Search For” blank, press Preview, and get 
a list of the indexed terms in that field.  Remember to set “Which Index” to “Words” 
or “Numbers/Dates” first, because Cardbox can’t guess which index to search if you 
haven’t typed anything into “Search For” that would give it a clue! 

• If you want to search for only some of the terms in the list, use Preview to bring up a 
list of index terms and then click or Ctrl + click on the ones you want to use in your 
search, to highlight them. 

• When you’ve highlighted all the terms you want, press OK and Cardbox will find the 
matching records.  This is especially useful if you are looking for misspelt or 
inappropriate index terms. 

 

   
 

Preview and Preview-and-Count are very similar.  Preview lists all matching index terms; 
Preview-and-Count counts how many records in the current selection match each term 
and if no records match, it doesn’t list the term  

Left: a Preview list.
Right: Preview-and-Count.

For full technical  details, 
do Help > Help Points and 

choose Help Point 532.
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Fuzzy matching 
Sometimes you’re not sure of the spelling of a word that you’re looking for: this is 
especially true of names.  One option is to use wildcards, but they aren’t always the best 
idea because they’re often too powerful.  COLO*R will find COLOR and COLOUR but it 
will also find COLONISER.  And is it STREATFIELD or STREATFEILD?  Finding a 
wildcard that matches both of them is a tedious effort.  In cases like this, fuzzy matching 
is the solution. 

In fuzzy matching, Cardbox finds index terms that almost match what you put in the 
“Search For” box.  What you put into the “Fuzziness” box dictate what Cardbox means 
by “almost matching” – anything from a one-letter difference upwards. 

Building up complex searches 
Go back to your original search for “London” in the Address field (remembering to start 
at Level 0, with 1000 records) and do it again. You’ll end up with 202 records and a 
status bar that says “Level 1”. 

Now, starting from Level 1, right-click on the Business column and type the word 
Accountant. 

You’ll end up with 11 records, representing the accountants in London. Cardbox has 
looked at the current selection (Level 1), picked out the records that match your new 
Select command, and created a new selection out of them.  In other words these two 
Select commands have combined, and the records you’re left with (at Level 2) are just 
those that match both the Select commands.  

This is a simple example but you can use the same principle to combine selections in 
any way you like, building up even the most complex searches in simple straightforward 
steps. 

History of Selections 
When you’re doing an elaborate search, it is useful to see exactly how far you’ve got 
and what commands you’ve used so far. The command for this is Search > History: try it 
now. 

You will see a list of the search commands you’ve used to get you to the current 
selection. Keep the History display around when you’re learning your way round 
Cardbox, because it will help you see where you’ve got to when you’re building up a 
really complex search. 

Highlight Matches 
Another useful command when you’re exploring is View > Highlight Matches. When you 
turn the “Highlight Matches” mode on and then enter a search command that looks for a 
word, Cardbox will highlight the word wherever it sees it in your record display.  This can 
be helpful if you’ve got a field with a lot of text in it and you want to see the word in its 
proper context. 

Commands that expand the current selection 

Include 
Include starts with the current selection. 

It creates a new selection from it, by adding to it every record in the database that 
matches the Include command. 

Select Also 
Select Also starts with the current selection. 

It creates a new selection from it, by adding to it every record from the previous 
selection that matches the Select Also command.  This sounds rather technical but it is 
often very useful: the Cardbox books and the help file give a detailed explanation. 

If you are used to Boolean 
logic, Select is AND, and 

Exclude is AND NOT.

In terms of Boolean logic, 
Include and Select Also 

both function as OR.

For details, 
open a search box and 

press F1 for on-line help.

Search > History 
Ctrl + H 
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Undoing search commands 

Undo One Level  
Undo goes back one level of selection: from Level 3 to Level 2, or from Level 1 to Level 
0.  For basic search commands, this is similar to undoing the last command. 

Clear All Selections 
Clear undoes all selections at once and gets you back to Level 0, where all the records 
in your database are visible and ready to be searched.  You can also use the toolbar to 
do this, by holding down the Ctrl key as you click on the Undo button. 

Other kinds of search 
Cardbox can do a lot more than just search on indexed words, numbers and dates. 

Data searches 
Normal Cardbox searches look at indexed words. You can also make Cardbox search 
all text (indexed and unindexed), although it’s a bit slower. To explore this option, look at 
the Search > Data menu.  Choose one of the search commands and then press F1 to 
see the on-line help. 

Relational linking 
In a relational link, you set up a search in one window, but instead of typing the text to 
be searched for yourself, you tell Cardbox to look in another window to find the search 
text. The result is a “live” link, because Cardbox repeats the search every time that the 
search text changes (for instance, because you move from one records to the next). 

Kept selections 
You can save any selection of records and give it a name, and you can later combine 
named selections together. Kept selections can be temporary (lasting until you close the 
database) or permanent. This feature has all sorts of uses: for more information, look at 
the Search > Keep menu and press F1 to see the on-line help. 

Combining selections from different windows 
Cardbox lets you open the same database in several windows.  Some people take 
advantage of this feature and use it to do separate searches in both windows.  If you do 
this, and then you want to combine the selections from both windows into one, do 
Window > Merge.  This will bring up a menu that lists the windows that are available: 
choose the window you want.  Window > Merge takes the current selection in the 
current window and creates a new selection consisting of all the records in that selection 
plus all the records that are in the current selection in the window you picked from the 
menu. 

 

Search > Undo 

Search > Clear 

This is a feature of the 
Professional Edition only. 

For full details, see  
Help Point 500.
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Tags and tagged searches 
Tags and tagged searches are unique to Cardbox. They’re so useful that we find it hard 
to understand why every database program doesn’t have them; but so far Cardbox is 
the only one.  If you do any database searching at all, tags will make a difference. Read 
about them and try playing with them: they can’t do any harm and they may make your 
life a lot easier! 

Let’s start with a definition: 

A tag is a temporary mark that you can make on the record you’re 
looking at.  Tags don’t alter the content of a record, they don’t 
change how the record looks when it’s printed, and if you’re on a 
network, other users of the database won’t be able to see your tags. 

Tagging is easy.  To tag or untag a record, move onto it and press the Tab key; or just 
hold down the Ctrl key and click on the record. 

So what are tags for? 

Just as you can search on indexed words, so you can search on tags. 

And that’s it.  The point of tags is that they form a quick and informal way of fine-tuning 
your searches or of putting complex searches together.  Here are a few examples. 

Fine-tuning a search 
Look through your selected records of accountants in London. As you glance through 
them, you may see that only some of them are really records that you want. Rather than 
invent a complex search that will exclude the unwanted records and leave you with the 
wanted ones, just do this: 

1. Tag the records you want. 

2. Use Search > Tag > Select to select them. 

Excluding specific records 
Tags have many other uses. Suppose that you’re preparing a big mailing and you’ve 
selected the records of the people you want to write to.  But you’ve talked to one or two 
of them recently, and you don’t want to send the usual standard letter to them because 
you want to write to them personally. 

1. If you want mailing labels as well as standard letters, print out the mailing labels. 

2. Tag the records of the people who should have personal letters. 

3. Use Search > Tag > Exclude to exclude them from the selection. 

4. Print out standard letters for everyone in the new selection. 

5. Use your favourite word processor to write those personal letters. 

(Without tags, you’d have had to design an extra field in your database saying “needs a 
personal letter” or “has been talked to recently”, which means more complication and 
more bureaucracy). 

The Tag menu 
Search > Tag opens the Tag menu. This contains commands to tag and untagged 
records and to do various searches based on taggedness.  

If you use the Tag menu a lot then you can promote it so that it becomes part of the 
menu bar at the top of Cardbox and you don’t need to open the Search menu every time 
you want to use it. 

Tag > Tag Record 
TAB 

To find out all about 
tags, open the Tag 

menu and press the 
F1 key for help. 
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Sorting 
Records in a Cardbox database naturally come in the order in which they were added, 
so that the first record that was put into the database comes first and the one that was 
added most recently comes last; but you can sort the records into any sequence you 
like, view them in their sorted sequence, print them, or write them to a file. 

Simple sorting 
Simple sorting is easy to specify and it is quite fast.  It is restricted to just one field, and 
Cardbox only looks at the first indexed term of that field.  This means that if you have a 
field that contains several indexed words, and you do a simple sort on that field, the 
records will be in alphabetical order as far as the first word is concerned, but the second 
and later words will be ignored. 

To do simple sorting using the mouse, move the mouse onto a field, press the right-
hand mouse button, but don’t release it for a few moments.  A menu will pop up.  
Choose the Sequence command, and Cardbox will do a simple sort on your chosen 
field, in ascending order. 

Try it now: sort your selected records on the Name field. To turn off the sorting, use the 
Sequence command again,  

The Sequence command  
View > Sequence is another way of sorting records. As well as doing a simple sort, it 
also lets you sort records into sequence on the basis of more than one field. For 
instance, if you had a database of addresses, you could sort your records according to 
the country, and then, within each country, on the town, and then, within each country 
and the town, on the name of the person or organisation.  You can specify ascending or 
descending order separately for each field in your list. 

To find out more, do View > Sequence and then press F1 for on-line help. 

View > Sequence 
Ctrl + U 
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When you have selected your records 
When you have selected your records, and sorted them into order, what do you do next? 

In many cases, of course, looking at the records on the screen – and perhaps editing 
them there – is all you need. Think, for example, of giving technical support by 
telephone: you take the call, look up the records, and write up the call afterwards. 

But there is a lot else you can do: 

Printing 
You can print one record or a whole selection of records.  

You can choose any format for printing, any sorted sequence, and any appearance.   

You can use File > Print Preview to preview your printed output before you actually send 
it to the printer.  

You can print on paper or on a sheet of mailing labels.  

To find out more about all this, do File > Print and then press F1 for on-line help. 

Data export 
Instead of printing your selected records you can export them to a file for another 
program to read. You have a wide variety of available output formats (including comma-
separated and XML) and you can also design specialised Cardbox formats for particular 
requirements. To find out more, do File > Export and then press F1 for on-line help. 

Fax 
You can send records by fax by printing them to a fax device; the Cardbox help file also 
gives some sample macros that you could use (with suitable fax software) to send 
customised bulk faxes (macros are part of the Professional Edition of Cardbox). 

Email 
Cardbox can create customised mail-merged emails and send them to multiple 
recipients using Tools > Bulk Email. Press F1 to find out more about this command.  

Alternatively, Cardbox can take your entire selection of records and send it, as a single 
email, to a recipient you designate. The command for this is File > Send as Email. 
Again, F1 will give you all the necessary information. 

If you don’t have direct access to Internet email then the Cardbox help file has sample 
macros for sending emails via Eudora and Microsoft Outlook. 

Finally, you can turn an email address into a clickable “hotlink”, anywhere in a record, by 
preceding it with the characters “mailto:”. This is why we have used “mailto:” as the 
caption for the Contacts database’s email field. 

These commands are 
part of the 

Professional Edition. 
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Images: documents and photographs 
Cardbox is not just about text. Apart from its text facilities, Cardbox has an image field 
that you can use to store anything visual – a photograph, drawing, scanned document, 
or fax. 

An image field can store multiple images. For example, if you wanted to store a 57-page 
document in a Cardbox record, each page would count as a separate image, and so the 
image field for that record would contain 57 images. 

The Property database 
The Property database is a sample database that has been used to store documents 
relating to the purchase and maintenance of a house. The purpose of the database is: 

• To have a record of all legal documents involved in the purchase of the house. 
• To have copies of all documents that might be needed when the house is sold. 
• To build an archive of all work that has been done on the house: specifications, 

guarantees, etc. 
• And, generally, to avoid getting buried under a flood of paper. 

Because you’re going to be downloading it, we’ve kept the sample database very small: 
4.5MB, holding 86 A4 pages. This makes an average of about 53KB per page.  Typed 
pages usually take less than this; pages full of photographs usually take more. 

Opening the Property database 
There is no need to close Contacts before opening Property: Cardbox can happily have 
many databases open at the same time. 

If you have downloaded the Property database into Cardbox’s Samples folder, use File 
> Open and then the Samples tab. 

If you haven’t, use File > Open and then the Server tab to open the database directly on 
the Cardbox Server. Because images can be large and Internet connections can be 
slow, you may occasionally see clocks instead of the image you’re expecting to see. 
Don’t worry: wait a moment and the clocks will disappear as the image arrives.  

What the Property database contains 
Mostly, this database looks like any other Cardbox database; but on the right-hand side 
of each record you’ll see a tiny representation of a printed page: this shows the first 
image that is attached to that record. 

 
The images are this small because that is the size we used for the image field. Later on 
we’ll show you a database where the image field is much bigger, but in this case we 
don’t intend to read the documents when they’re shown as part of a record, only when 
we are viewing them on their own. 
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Viewing images in the Image window 
Hit F12, and you will see the first page of the document attached to the current record. 

 

Multiple images and the image browse bar 
On the left of the status bar at the bottom of the image window you’ll see what looks like 
an ordinary Cardbox browse bar, except that it’s shorter and the corrugations are a 
different shape.  This is the image browse bar.  It tells you which image you’re looking at 
and how many images there are in the current record.  You can drag the slider or click 
on the arrows to move forward and back through the images. 

Using the keyboard to browse through images 
Here are the keyboard commands for browsing through the images attached to a record: 

 

Right arrow 

Down arrow 
Next image. 

Left arrow 

Up arrow 
Previous image. 

Home First image. 

End Last image. 

View > Images 
F12 
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More about keystrokes for browsing 
You have already seen that: 

• When you are viewing records, the arrow keys browse between records. 
• When you are in the Image window, the arrow keys browse between images. 

What about browsing between images when you’re viewing records, or browsing 
between records when you’re in the Image window? Here are the remaining two rules: 

• When you are viewing records, you can browse between images by holding down 
the Alt key and using the normal image-browsing keystrokes. 

• When you are in the Image window, you can browse between records by holding 
down the Alt key and using the normal record-browsing keystrokes. 

Zooming in and out 
The zoom control is at the bottom of the image window. 

To zoom in: click on the large magnifying glass, or hold down the Ctrl key and press + 
(plus) on the numeric keypad. 

To zoom out: click on the small magnifying glass, or hold down the Ctrl key and press - 
(minus) on the numeric keypad. 

If you have a mouse with a wheel, you can use the wheel for zooming: hold down the 
Ctrl key and roll the wheel away from you to zoom out or towards you to zoom in. 

The zoom menu 
For more detailed control of zooming, open the Zoom menu by clicking on the white 
area between the magnifying glass symbols. 

For browsing through documents the best settings are the following: 

Fit Width – makes the image as wide as possible while still fitting inside the width of the 
window: the result may be an image that is too tall for the window and needs to be 
scrolled vertically. 

Fit In Window – makes the image as big as possible while still fitting entirely within the 
window, with no scrolling. 

Image size, 100% – shows the image on the screen at the same size as it originally was 
on paper. 

Try each of these settings and see which one you like best. 

Background information: Pixel Count and Image Size 

There are two ways for Cardbox to measure the amount by which an image is being 
zoomed.  In the Pixel Count mode, a zoom factor of 100% means that Cardbox displays 
one pixel on the screen for every pixel in the image.  In the Image Size mode, a zoom 
factor of 100% means that Cardbox makes one inch of the image take up one “screen 
inch” on the screen.  The size of a “screen inch” is something that has been decided by 
the manufacturer of your computer screen: a common convention is to have 96 pixels 
per screen inch, which usually makes a screen inch rather more than 2.54 centimetres 
in size. 

The reason why these two zoom modes are different is that not every image is created 
with the same resolution as your screen: it all depends where the image has come from 
(scanner, camera, fax) and how it has been processed.  Image Size mode is usually 
best for faxes and scanned documents and Pixel Count mode is usually best for digital  
photographs. 



    20   

Scrolling 
When you are viewing an image that is larger than the available space, you’ll see scroll 
bars next to it.  You can use the scroll bars to scroll a large image, or you can simply 
place the mouse inside the image, hold down the left mouse button, and drag the image 
in the direction you want. 

If you have a mouse with a wheel, you can use the wheel to scroll vertically.  To scroll 
horizontally, hold down the Shift key while you are using the wheel. 

Thumbnail display 
On the left-hand side, the image window can display miniature “thumbnail” versions of 
your images.  You can use these to decide which image you want to look at, if you have 
several images attached to a record.  Thumbnails are more useful for photographs than 
for scanned documents, because at thumbnail size all documents look much the same. 

You can turn thumbnail display on and off by clicking on the  button at the 
bottom of the image window, or by pressing the F4 key, or by right-clicking 
anywhere in the image window and selecting “Thumbnails” from the pop-up menu.   

Searching the Property database 
By now you know Cardbox well enough to be able to look at the screen and see the 
indexed words that you will be able to use for searching. You can also see that this 
database is still in a fairly rudimentary state. If it gets much bigger, it will need 
classification fields such as “Legal”, “Works”, “Guarantees”, and so on. The design of 
Cardbox makes this very easy to do: you can add a new field to your format design at 
any time, and a combination of tagging and batch-editing will rapidly let you go through 
your existing records and fill your new field with meaningful information. 

You can’t search inside an image. To a computer, an image is just a pattern of 
differently coloured pixels. Even if the image happens to look to you like a printed page, 
to the computer it’s just dots and can’t be searched. If you want to scan documents and 
search for words within the scanned text, you need optical character recognition (OCR) 
software such as ABBYY FineReader. 

When you have found your documents 
You can print them. Cardbox lets you print individual images, or all the images attached 
to a record, or selected images (you mark the ones you want by marking their 
thumbnails in the Image window). 

You can write them out to files and burn them to CDROM for a friend. 

You can fax them. For Windows, faxing is just a different kind of printing. 

You can send them as attachments to an email (Professional Edition only). 

Finally, you can copy an image to the Clipboard for use by some other program. 

Should you keep the original documents? 
It depends. Some documents, such as leases or guarantees, are important and you 
should keep them. Others can be thrown away: if you ever need to refer to one of these, 
you can print it out from Cardbox. 

For the documents you do need to keep, the nice thing about using Cardbox is that your 
physical filing system doesn’t need to be very sophisticated: just number the documents, 
file them in numerical order, and store the numbers as part of your Cardbox record. You 
don’t need to gather the physical documents into categories because all the 
categorisation and classification is done in Cardbox. 

You’ve already read 
about tagging. We’ll 
cover batch editing 
when we describe 
editing in general. 
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The Photos database 
The Photos database is a sample database that has been used to index a collection of 
digital photographs. 

The first thing you have to decide about a digital photography database is what it should 
store. Should it store the photographs themselves, or should it store pictures of those 
photographs? 

Storing the photographs themselves – this is the simplest approach, because then 
the Cardbox images have the full quality of the original and you don’t need to keep 
the camera’s JPEG images as separate files. But digital photographs are large. The 
photographs in the Photos collection were taken by a Canon Ixus 50 digital camera, 
which on its 5-megapixel setting produces images that take between 900KB and 
2.6MB of disk space. This means that an 80GB hard disk would hold from 30,000 to 
80,000 photographs, but the crucial point is backup: a single 4.7GB DVD would only 
hold between 2,000 and 4,000 photographs. If you exceeded that limit, you would 
have to split the database file among separate DVDs, which would make life a bit 
more complicated. 

Storing pictures of the photographs – by this, we mean storing the photographs in 
Cardbox at a lower resolution (for example, 800 by 600 pixels) and keeping the 
original JPEG image files elsewhere. The lower resolution is still good enough for a 
computer screen, and you’d only need to refer to the originals if you wanted to make 
prints or enlargements. You could accumulate your original JPEG files in a folder on 
your hard disk, and burn them onto a CDROM whenever you had enough files to fill 
the CD. You could allocate a field in the database to say which CD, and which 
filename, contains the original JPEG image if you want to print it or process it in 
Photoshop. Photo libraries often use this kind of approach because (with a careful 
choice of resolution) they can give away their entire collection as a database and 
then provide high-quality versions of the images that their clients ask for. 

For the Photos database we’ve taken the second approach. It contains 74 pictures, and 
if we’d stored the original photographs in Cardbox the database would have come out at 
around 120 megabytes – we don’t think you’d appreciate having to download or install a 
database that large, just so you can see how Cardbox manages pictures! 

Opening the Photos database 
If you have downloaded the Photos database into Cardbox’s Samples folder, use File > 
Open and then the Samples tab.  If you haven’t, use File > Open and then the Server 
tab to open the database directly on the Cardbox Server.  

What the Photos database contains 
The database contains the following fields: 

NUMBER – the number that the camera has given to this photograph. This also lets us 
work out the filename of the JPEG file that contains this photograph. 

DATE – the date and time that the photograph was taken. The format may look a little 
unfamiliar but it lets the camera report the time to the nearest second. 

CIRCS – the circumstances under which the photograph was taken: day or night, interior 
or exterior. You can design as many fields and codes of this type as you need to 
help you classify your collection. 

WEB – a relevant web address, where one exists. These addresses are hotlinks and if 
you click on one, the page will open in your web browser. 

WHERE, COUNTRY, SUBJECT – more information about the photograph. We’ve 
chosen not to specify the country if it is within the United Kingdom, but you can 
establish your own conventions. 

There is nothing to stop you creating more fields. Examples include: the genre (scenery, 
architecture, action, portrait, food,…), the names or initials of people in the picture, the 
names or initials of people who have asked you for a copy of the picture. 

In the sample Photos 
database the pictures 

take an average of 
about 58KB each. 
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Searching the DATE field 
There are some useful wildcards that you can use when searching for dates in the high-
tech date-and-time format: 

• Searching for 21/7/2005* or 2005.07.21* will find everything on 21 July 2005, 
at any time of day. 

• Searching for 8/2005* or 08/2005* or 2005.08* will find everything in 
August 2005. 

 

Viewing images on their own: the “Image Alone” view 
When you want to take your laptop and show your photographs to your friends, you can 
do it easily with Cardbox: find the records you want, then hit F12 for the Image window, 
then move through your selection with Alt + right-arrow. But there is a snag: they’ll see 
the status bar and the toolbar as well as your pictures. 

If you want to see the pictures and nothing but the pictures, go into the Image window 
and either click on the Maximize button at the top right, or right-click on the picture and 
select “Image Alone”. 

Once you’re in the Image Alone mode, you can get out of it by using the right-click 
menu, but the quickest way of all is just to hit the Esc key. 
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Adding and editing records 
Now that you’ve tried looking into and exploring a Cardbox database, it’s time to try 
adding and editing a few records. Once you’ve done that, we can move on to creating a 
database design of your own. 

Before you start 
Have a look at the Cardbox toolbar. Are the Edit Record and New Record buttons 
clearly visible, or are they disabled and displayed in shades of grey? 

    
If they’re disabled then this means that your current database access is read-only. This 
usually means that the database is in the Samples folder, or that you’re using a sample 
database on our Cardbox Server.  But it could also mean that you need to install a 
licence into your copy of Cardbox.  

Whatever the reason, look at Help Point 800 to find out how to get to the point where 
you are allowed to edit. 

Double-click = Edit 
The simplest way to edit an existing record is to double-click on it.  But you can also use 
Edit > Edit Record to edit the current record: this starts editing and positions you at the 
beginning of the first field. 

Most of the business of editing records in Cardbox is like editing text anywhere else in 
Windows. All the normal features are there: typing, inserting, replacing, highlighting text, 
dragging and dropping, copying and pasting, and even a spelling checker. 

Moving between fields 
You’ll see that the record you’re editing is divided into separate fields. To move from one 
field to the next, press the Tab key.  You can also click on the field you want to go to, or 
press Ctrl + G and select the field name from a list. 

Indexing and unindexing text 
The editing feature that you won’t be familiar with from other Windows programs is the 
indexing and unindexing of text. When a field is first designed in Cardbox, you give it 
one of four indexing modes: 

None – nothing is indexed. 

All – everything is indexed. 

Manual – to start with, nothing is indexed, but you can tell Cardbox to index particular 
words. 

Auto – to start with, everything is indexed, but you can tell Cardbox not to index 
particular words.  

You can usually see which words are indexed and which aren’t because the indexed 
terms appear as bold text, or red text, or both. But this is simply because most people 
design their Cardbox formats that way: it is also possible to have indexed and unindexed 
terms looking identical. In that case you can see whether a particular term is indexed by 
moving onto it and looking at the status bar. 

To index or unindex a word, move onto it and do one of the following: 

• Tap the Ctrl key. 

• Type Ctrl + I. 

• Right-click and select “Indexed” from the menu that pops up. 

You can index or unindex a whole series of words by selecting them all and then using 
one of the indexing commands. 

If you want to know why a 
toolbar button is disabled, 
move the mouse onto the 

button and wait a couple of 
seconds: Cardbox will tell you 

the reason. 

Edit > Edit Record 
Ctrl + E 

The order in which fields are 
visited by the Tab key is 

something that you set up when 
you design a format.

These commands won’t work in 
fields whose indexing is None 
or All, because in those fields 
the indexing is fixed and can’t 

be changed.

Help > Help Points » 800
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Saving your changes 
File > Save stops editing and saves any changes that you have made. 

Saving your changes as a new record 
This saves the record, with all the changes you have made, as a new record.  The 
original record (the one that you started editing) is left unchanged.  This is the traditional 
Windows method for creating a modified duplicate, but we strongly recommend that you 
use Edit > Duplicate Record instead, because it’s much safer. 

Adding a record based on an existing one 
Some databases are very repetitive and you often find yourself wanting to add a new 
record that’s almost identical to one that is already there.  To create a new record that 
resembles an existing one, go to the existing record and use Edit > Duplicate Record.  
This creates a new record just like Edit > New Record but instead of being blank, the 
record contains exactly the same data as the current record when you issued the 
Duplicate command.  Now you can make any changes that you need and then use File 
> Save.  The new record will become part of the database, and the original record will 
be left unchanged. 

The Duplicate command is unique to Cardbox. It is a lot safer than just editing a record 
and using Save As, because there is no risk of you overwriting your original record by 
using the Save command by mistake. 

Adding a blank record 
Edit > New Record creates a new, blank record for you to type into.  When you have 
finished, use File > Save, and the record will become part of the database. As far as 
Cardbox is concerned, typing into a blank record is just like editing an existing one, 
except that the record is blank to start with: all the editing commands are the same. 

Importing records from outside 
If you have records in a different database, or even in a text file of a certain format (for 
instance, comma-separated) then you can import the data by using commands in the 
File > Import menu. These commands are sophisticated and we won’t go into them 
here, but you can read more about them in the on-line help.  

File > Save 
Ctrl + S 

File > Save as New 
 

Edit > Duplicate 
Ctrl + D 

File > Save 
Ctrl + S 

Edit > New Record 
Ctrl + N 

File > Save 
Ctrl + S 
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Editing a batch of records 
Batch editing is a unique feature of Cardbox and it saves a lot of time. For example, 
when we put “Greece” into the Country field of the Photos database, we didn’t edit the 
records one by one. Here’s what we did instead: 

1. Go through the records and hit the Tab key to tag the ones we want to edit. 

2. Use Tag > Select to select the tagged records. 

3. Use Edit > Batch > Edit (or Ctrl + B) to edit the first record. 

4. Type “Greece” into the Country field. 

5. Save. 

… and Cardbox did all the rest for us automatically. 

We did the same thing in many other cases: for example, to put “INT DAY” or “EXT 
NIGHT” into the Circs field.  

Batch editing is useful without tagging as well. Suppose you have selected records for a 
mailing, and want to update a “date last sent” field to show what you have done. Batch 
Edit makes this quick and easy. 

Batch Edit works very simply indeed. When you start it, you start editing the record 
you’re on, but as well as doing what you say, Cardbox records all the editing actions that 
you take.  When you save the record, Cardbox will go to the next record and play back 
all the actions it’s recorded.  The editing actions can be as simple or as complicated as 
you like: you can index a word, or you can erase a field and replace its contents, or you 
can do some major reshuffling of data. 

When you are batch editing you can tell Cardbox to pause after each record, so that you 
can decide when you want it to stop editing; or you can tell Cardbox to go straight ahead 
and edit the whole of the current selection automatically without pausing. 
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Scanning documents and photographs 
If you’re interested in making a database that stores documents or photographs, try 
opening the Property or Photos database, creating a new record and scanning some 
images into it. Cardbox can receive images from any scanner that uses the industry-
standard TWAIN interface. 

While editing a record, you can scan an image by right-clicking on the image field and 
selecting “Scan” from the pop-up menu. 

While you are in the image window, you can scan an image by clicking on the toolbar 
button, or pressing Ctrl + N, or right-clicking anywhere in the image window and 
selecting “Scan” from the pop-up menu. 

 

Source If you have more than one TWAIN device (for example, a scanner and 
a camera), then choose which one you want to use. 

Scan As This option helps Cardbox to negotiate the correct scanning mode and 
resolution with the scanner. 

Picture is a continuous-tone image such as a photograph. 

Document is a printed or handwritten document, or a line drawing. 

Compressed Document tells Cardbox that this document will be 
stored in Compressed format, which is slightly fuzzier but uses a lot 
less disk space.  

Monochrome Set this option if you want the scanner to ignore any colour when 
scanning the image. 

If you press the Quick Scan button, the scanner will start at once.  It will scan one page, 
and then you will be returned to the Scan Image window.  You can then change the 
paper and press Quick Scan again, or you can press Close to return to Cardbox. 

Quick Scan uses standard default settings for things like the scanner resolution (dots 
per inch). To have detailed control of the settings, use the Scan button instead of Quick 
Scan. 

Importing photographs from a camera 
If you have a digital camera then you may want to try how Cardbox works with it. Again, 
open the Property or Photos database and create a new record, so that you have 
somewhere to store the images you import. 

When you take photographs with a digital camera, you normally have two options for 
getting them into your computer: you can take the memory card out of the camera and 
plug it into your computer, or you can plug the camera directly into the computer. 

In both cases your photographs will normally end up looking like files inside a folder in 
Windows. Here are the commands for importing image files into Cardbox: 

While editing a record, you can read an image from a file by selecting the image field 
and using Edit > Insert Object, or by right-clicking on it and selecting “Load From 
File” from the pop-up menu. 

While you are in the image window, you can read an image from a file by clicking on 
the toolbar button, or pressing Ctrl + R, or right-clicking anywhere in the image 
window and selecting “Load From File” from the pop-up menu. 

Importing batches of images 
If you have the Professional Edition of Cardbox, it is possible to write macros that read 
every image file in a given directory. We used one like this to import the images for the 
Photos database: it automatically resized the images for us and even extracted the date 
and time that the photograph had been taken. 



      Options when scanning and importing  27 

Options when scanning and importing 

Quality: the Store Compressed option 
After you’ve scanned or imported an image, right-click on it and you’ll see an option 
called Store Compressed. Turning this on reduces the amount of disk space the image 
will need, by reducing the image quality slightly. The best way of assessing this option is 
to try it out. Most of the images in our two sample image databases were stored with 
Store Compressed turned on. 

If you look at the second record in the Photos database (the picture of a single windmill) 
you will see that it has two images attached. The first is stored with Store Compressed, 
the second isn’t. The disk space used is 41KB and 66KB respectively. You have to look 
very hard to see the differences between the images: try viewing them in the Image 
window and look at the detail in the bottom sail of the windmill, near the horizon. 

Size: the Override Size option 
By default, Cardbox stores an image the size it actually is: an image 2048 x 1536 pixels 
will be stored as 2048 x 1536 pixels. With photographs especially, you may want to 
reduce the size of the image so that it takes less space on the disk. To do this, right-click 
on the image and select “Override Size” from the Preprocess menu. If you need help 
with the options for this command, press the F1 key. 

Image rotation 
You can also rotate an image if it happens to have come out upside down or sideways: 
again, use the Preprocess menu. You won’t need to do this very often if you have a 
modern digital camera that uses the Exif specification, because that notes the 
orientation of the camera (vertical or horizontal) when the photograph was taken and 
Cardbox adjusts the picture on the screen accordingly. 

The bottom right-hand corner 
of the Image window shows 
you the size in pixels of the 

current image and how many 
KB of space it takes. 
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Formats and format design 
So far you’ve learnt how to look at a Cardbox database, search it, and add or edit 
records. All that is left now is to understand how the underlying formats work, so that 
you can design databases of your own or modify an existing design. 

Looking at a format 
Open the Contacts database and view it in its native format (use View > Change Format 
if you’re not already in the native format). 

Now use the Edit Format command. You’re not actually going to make changes to the 
format, but this is the best way of seeing what the format contains. 

 
You can see that the format contains items corresponding to what you see on the 
screen when you look at a record: fields, captions, lines and boxes.  Each of these 
things is a separate item in the format: you can double-click on it to find out more about 
its properties.  

Try this now. If you want to know what the properties mean, press F1 while you’re in the 
Properties window. 

When you’ve finished exploring, quit without saving the format (this is so that you don’t 
make changes by accident). 

Have a look at other formats in the same way. You’ll find the Demonstration Letter 
format interesting because it contains a new kind of format item, a “merge block”. Merge 
blocks combine fields and words into a single piece of continuous text, ideal for mail-
merging. The Label format also uses a merge block to combine fields into a single item. 

There are two item types that aren’t in our sample databases. The Graphic type puts a 
picture or a logo in a format – it’s different from an image field because the graphic isn’t 
part of the record data and appears the same in every record. Graphic items are good 
for corporate logos and letterheads. 

The Pushbutton type puts a pushbutton in a format – clicking on the pushbutton will 
perform an action that you define when you create the pushbutton item. Pushbuttons are 
closely associated with macros and programming, which are features of the Professional 
Edition of Cardbox.  

Edit > Format > Edit 
Ctrl + Shift + E 

File > Quit 
Ctrl + Q 
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Adding fields to the native format 
The Property database that we’ve given you is fairly simple. Let’s add a couple of fields 
to it, to divide the documents into categories and indicate which ones we’ve filed and 
which ones we’ve thrown away after scanning. 

Start by opening the Property database and making sure you’re in the native format. 
Then do  Edit > Format > Edit (or use Ctrl + Shift + E, which is a very convenient shape 
for a shortcut). 

Inserting a field in the native format 
Inserting a field into the native format effectively creates it in the database.   

1. Do Insert > Field. The mouse cursor turns into a hollow square.  Move the mouse to 
just below the start of the SUBJECT field, press the mouse button, hold it down, 
drag the mouse to the right until the new field is about as wide as SUBJECT, then 
release the mouse button. 

2. Cardbox will ask you what name you want to give to the field. Type CLASS. 

3. The Field Properties window will open. Type “Classification: ” into the Caption box 
(type a colon and a space after the word, just as we’ve shown you). Set the index 
mode to All. 

Now save the native format and look at what you’ve done. 

You’ll see that every record contains a new field, just below the existing SUBJECT field. 
The new field is blank, of course, because you haven’t put any data into it yet. 

Putting data into the field 

We’re not going to help you with the really hard bit, which is to decide what classification 
codes you’d like to use. It’s up to you to decide how you want to categorize your 
documents, because it all depends on what sort of documents you want to store. One 
example might be House, Building, Utilities, Legal, Insurance, Car, Health.  

Remember that you can put documents in more than one category at once if you want 
to. For example, you might mark a particular document as Car Insurance, in which case 
you’d find it if you searched for “Car” (along with the original brochure and all your 
maintenance records) and also if you searched for “Insurance” (along with house 
insurance, travel insurance and life insurance). If you wanted to search for car insurance 
documents only then you could enter a Select command with “Car insurance” and turn 
on the Match All option so that Cardbox finds only the records where both those words 
occur. 

Whole books have been written about household filing systems, and we’re not going to 
summarise them here! 

One of the great things about Cardbox is that you can always “get it wrong first time”. If 
you find that you need an extra category, think of a code and use it. You can tag and 
batch-edit to add the new category to any existing documents that need it, or you can 
batch-edit and search-and-replace if you want to change the name of an existing 
category. Once you’ve got a hundred or so documents in your database you’ll find that 
you’ve got the whole classification scheme worked out the way you want it. 

Radio buttons and check boxes 

You could follow the example of the Contacts database and display your Classification 
field as a set of radio buttons or check boxes – even as a drop-down list. Whether you 
do this depends on your temperament. Using radio buttons (etc) means that you pre-
define, in your format, what codes and categories you are going to use. You may 
welcome the guidance and discipline that this gives you when you’re entering data; on 
the other hand, you may find it irksome to have to edit the format if you decide that you 
want to add a new category. It’s up to you. 

Insert > Field 
Ctrl + F 

If you don’t get the field’s 
position exactly right, don’t 

worry: we’ll show you how to 
sort this out in a minute.

File > Save 
Ctrl + S 
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More changes in the native format 
Edit the native format again. 

Adding a caption 

It looks a little silly to have the Classification field with a caption when the Subject field 
doesn’t have one. So double-click on the SUBJECT field, and type “Subject: “ into the 
Caption box (remembering to include the colon and the space after the colon). 

Moving a field to make room 

Now we’re going to add a field just after NUMBER, to say whether we’ve kept a paper 
copy of the document. First of all we need to make some room by making WHO a little 
bit shorter. 

Click on the WHO field and you’ll see some square blue blobs appear: these are “sizing 
handles”. Move the mouse onto the middle one on the left-hand side, press the mouse 
button and drag to the right until the status bar (at the bottom right-hand corner of the 
screen) says “Column=30”. Then release the mouse. 

If you find this rather fiddly, try zooming in on the display by using the Zoom In button on 
the toolbar. Or use the keyboard instead of the mouse: hold down the Shift key and 
press the left arrow 10 times to make the WHO field smaller, then release the Shift key 
and press the right arrow 10 times to move the field to the right. 

Adding another new field 

1. Do Insert > Field. Move the mouse just to the right of the NUMBER field, press the 
button, drag until it’s just to the left of the WHO field, release the button. 

2. Give the field the name FILED. In Field Properties, type “Whether a paper copy is 
filed” into the Description box, set the index mode to All, and select “Check boxes” 
from the View list. 

3. Press the Set button next to the View list, and type Y=Filed into the empty box 
that appears. Press OK, then OK again. This has told Cardbox to create a check box 
called “Filed” on the screen, and to store Y in the FILED field whenever that check 
box is turned on (the online help would have told you this if you’d pressed F1 before 
typing). 

Changing the order in which fields are visited 

When you edit a record, the Tab key takes you to the next field. What “Next” means 
depends on how you have defined the field sequence when you designed the format. 
Before you save the native format, let’s have a look at the sequence and change it if 
necessary. 

1. Do View > Sequence of Fields (alternatively, double-click on the format background 
and open the Field Sequence tab in the window that appears). You’ll see a list of 
fields that shows the order in which the Tab key would visit them when editing. 

2. Click on FILED, to highlight it, and then click on the up arrow at the bottom of the 
field list, until FILED is between NUMBER and WHO. Then click on OK.  

Now save the native format and look at what you’ve done. 

You’ll see that every record contains a check box between the number and the WHO 
field. The check box is blank because you haven’t put any data into it yet. 

Edit a few records and turn on the check box in some of them. This will come in useful in 
a minute, when we look at viewing the data in an alternative format. 
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Creating an alternative format 
Let’s create a format that is just a summary list of documents, one line per document 
with a heading at the top of the list. You might use it if you wanted to print out an 
inventory of the papers you hold on a particular subject. 

Edit > Format > New creates a new, blank format as a basis for your design.  

Inserting the fields 
Use Insert > Field to insert fields as follows: 

NUMBER – columns 1 to 5. 

FILED – columns 6 to 7. 

DATE – columns 9 to 20. 

CLASS – columns 22to 31. 

WHO – columns 33 to 47. 

SUBJECT – columns 49 to 86. 

You’ll see that Cardbox asks you to pick a field name immediately you start inserting (it 
gives you a list of available names). This is because alternative formats can only contain 
fields that already exist in the native format. For the same reason, you’ll see that most of 
the options in Field Properties are greyed out and unavailable. In fact, in this format we 
don’t want to set any options anyway: there are no captions, and we don’t even give a 
View setting to the FILED field. 

Creating the heading 
We want to have a heading in this format, so we need to make some room for it. Do 
Insert > Headings/Footings > Page Heading and you’ll see a subtle change on the left of 
the window. Instead of a single row number (1) you now have two row numbers, H1 
and 1. Anything you put into row H1 will be part of the heading. 

Do Insert > Fixed Text. The mouse cursor turns into a hollow square.  Move the mouse 
to column 1 of the heading, just above NUMBER, and click once. The Text Properties 
window will open: type “No./Filed” in the Text box. 

In the same way, put “Date” into column 9, “Category” into column 21, “Who” into 
column 32, and “Subject” into column 48. 

We’ll want to see the heading on the screen as well as on any printed output, so double-
click on the format background, and turn on “Screen display also shows page headings” 
in the General tab of the Format Properties window.  

This format is meant for display rather than editing, but just in case you ever do decide 
to use it for editing, you can use the Field Sequence page in Format Properties to 
reshuffle the fields so that they are in the same order that’s visible on the screen. 

As an exercise you can also change the appearance of the format, either with View > 
Appearance or by using the Appearance tab in Format Properties.  Change the “Normal” 
font to Arial and the background to white. Change the “Indexed” text to be black and not 
bold. Change the “Fixed text / Captions” text to be dark blue, bold, and 8-point in size, 
with a white background. 

 
Finally, do File > Save and give “Summary” as the name of the new format. 

Edit > Format > New 
Ctrl + Shift + N 

Insert > Fixed Text 
Ctrl + T 

Not giving FILED a View 
setting means that it’ll display 
the single letter Y if the check 

box was turned on and 
nothing at all if it wasn’t. This 

saves space on the screen 
and in the printed list.
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What the result looks like on the screen 

 
To get this list, we right-clicked on the “Who” column and typed “CHH” as the text to be 
searched for. 

Another way of creating alternative formats 
You may well find that you already have an alternative format similar to the one you 
want to create. In that case, use View > Change Format to get to that format, then do 
Edit > Format > Duplicate. This will create a new format for you, just like Edit > Format > 
New, but the new format will start off as an identical copy of the existing format. This 
saves a lot of time and trouble, especially if you are creating mail-merged standard letter 
formats where one format is much like another. 

Creating a new database 
By now you have learnt everything you need to know to start creating databases of your 
own. Here’s a summary of how it happens: 

1. File > New Database. 

2. Edit > Format > Edit. 

3. Add some fields to the format. 

4. File > Save to save the format. 

5. Edit > New Record to add your first record. 

 Of course we can’t summarise the whole of the 300-page Cardbox Book in thirty-odd 
pages, but by now you should have a good feel for what Cardbox can do for you, and 
the best thing you can do now is to play with Cardbox on your own and learn your way 
round in greater detail. 

Read The Cardbox Book if you have it, or the Home Edition manual, which has the 
same contents.  Use the Cardbox help file for more detailed guidance. 

If you don’t have one of our books then go to the Gallery section of the Cardbox web 
site: in “The Cardbox Gallery” you’ll find a document called Inspiration, which shows you 
how other people are using Cardbox and gives you ideas for applications of your own. 

Look through our sample databases as well. If you find one that you like the look of, 
you’re welcome to make a copy and start your own design on that basis. 
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